Count the string
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8965 Accepted Submission(s): 4174
Problem Description It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
Input The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
Output For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007. Sample Input
1
4
abab
Sample Output
6
Author [email protected] Source HDOJ Monthly Contest – 2010.03.06 Recommend lcy
題意:給以字元串計算出以前i個字元為字首的字元中在主串中出現的次數和
解題思路:next[i]記錄的是長度為i不包括自身的最大首尾重複子串長度,sum[i]記錄長度為next[i]的字首所重複出現的次數
#include <iostream>
#include <stdio.h>
#include <queue>
#include <cstring>
#include <stack>
using namespace std;
char a[200009];
int nt[200009];
int sum[200009];
int n;
void get_next()
{
nt[0]=-1;
for(int i=0; i<n; i++)
{
int k=nt[i];
while(k>=0&&a[i]!=a[k])
k=nt[k];
nt[i+1]=k+1;
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
scanf("%s",a);
get_next();
int ans=0;
sum[0]=0;
for(int i=1;i<=n;i++)
{
sum[i]=(sum[nt[i]]+1)%10007;
ans+=sum[i];
ans%=10007;
}
printf("%d\n",ans);
}
return 0;
}