天天看點

HDU 1671 字典樹水題 Phone List

Problem Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

1. Emergency 911

2. Alice 97 625 999

3. Bob 91 12 54 26

In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2 3 911 97625999 91125426 5 113 12340 123440 12345 98346

Sample Output

NO YES

題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=1671

題目大意:  看一堆電話号碼中是不是某個電話号碼是其中一個電話号碼的字首 如果有 則不能打通 輸出NO 沒有就全部能連通 輸出YES

添加兩個标價, 一個是flag2,用來表示是否有一個串在該節點結束,這主要是針對前面的串中出現過目前串的字首;

另一個是flag1,用來标志目前當一個串結束時,它是否存在下一個節點,主要針對目前串是之前出現過的串的字首

需要注意的是, 這道題必須釋放記憶體, 否則會MLE ....

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 20 ;

struct Node{
    Node *next[10] ;
    int flag1, flag2 ;
    Node(){
        for (int i = 0; i < 10; i++){
            next[i] = NULL;
        }
        flag1 = 0, flag2 =0;
    }
};

Node *root ;
bool flag ;

void insert (char *s){
    Node *p = root ;
    for (int i = 0; s[i]; i++){
        int id = s[i] - '0' ;
        if (p -> next[id] == NULL){
            p ->flag1 = 1;
            p -> next[id] = new Node() ;
        }
        p -> flag1 = 1;
        p = p -> next[id] ;
        if (p -> flag2 == -1) flag = 1;
    }
    p -> flag2 = -1;
    if (p -> flag1) flag = 1;
}

void del (Node *p){
    for (int i = 0; i < 10; i++){
        if (p -> next[i] != NULL){
            del(p -> next[i]) ;
        }
    }
    delete p ;
}

int main (){
    int n ,m ;
    char s[maxn] ;
    scanf("%d", &m);
    while (m--){
        flag = 0;
        root = new Node();
        scanf("%d", &n);
        getchar() ;
        while (n--){
            gets(s) ;
            if (flag) continue ;
            insert(s);
//            cout << "text\n" ;
        }
        if (!flag) puts("YES");
        else puts("NO");
        del(root) ;
    }
    return 0;
}