天天看點

連結 / Connectivity(AtCoder-2159)Problem DescriptionConstraintsInputOutputExampleSource Program

Problem Description

There are N cities. There are also K roads and L railways, extending between the cities. The i-th road bidirectionally connects the pi-th and qi-th cities, and the i-th railway bidirectionally connects the ri-th and si-th cities. No two roads connect the same pair of cities. Similarly, no two railways connect the same pair of cities.

We will say city A and B are connected by roads if city B is reachable from city A by traversing some number of roads. Here, any city is considered to be connected to itself by roads. We will also define connectivity by railways similarly.

For each city, find the number of the cities connected to that city by both roads and railways.

Constraints

  • 2≦N≦2*105
  • 1≦K,L≦105
  • 1≦pi,qi,ri,si≦N
  • pi<qi
  • ri<si
  • When i≠j, (pi,qi)≠(pj,qj)
  • When i≠j, (ri,si)≠(rj,sj)

Input

The input is given from Standard Input in the following format:

N K L

p1 q1

:

pK qK

r1 s1

:

rL sL

Output

Print N integers. The i-th of them should represent the number of the cities connected to the i-th city by both roads and railways.

Example

Sample Input 1

4 3 1

1 2

2 3

3 4

2 3

Sample Output 1

1 2 2 1

All the four cities are connected to each other by roads.

By railways, only the second and third cities are connected. Thus, the answers for the cities are 1,2,2 and 1, respectively.

Sample Input 2

4 2 2

1 2

2 3

1 4

2 3

Sample Output 2

1 2 2 1

Sample Input 3

7 4 4

1 2

2 3

2 5

6 7

3 5

4 5

3 4

6 7

Sample Output 3

1 1 2 1 2 2 2

題意:n 個點 k 條公路 l 條鐵路,分别給出兩種路連接配接的城市,對于每個城市,求可以通過公路、鐵路都能到達的城市有幾個,包括其自身

思路:首先對于公路與鐵路,利用并查集求出他們的連通塊,由于要求通過公路、鐵路都能到達的城市,是以直接求兩個并查集的交集即可,利用 map+pair 統計即可

Source Program

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define EPS 1e-9
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LL long long
const int MOD = 1E9+7;
const int N = 200000+5;
const int dx[] = {0,0,-1,1,-1,-1,1,1};
const int dy[] = {-1,1,0,0,-1,1,-1,1};
using namespace std;
int fatherRoad[N],fatherRail[N];
int Find(int father[],int x){
    if(x!=father[x])
        return father[x]=Find(father,father[x]);
    return x;
}
void Union(int father[],int x,int y){
    x=Find(father,x);
    y=Find(father,y);
    if(x!=y)
        father[y]=x;
}
int main() {
    int n,k,l;
    scanf("%d%d%d",&n,&k,&l);
    for(int i=1;i<=n;i++){
        fatherRoad[i]=i;
        fatherRail[i]=i;
    }
    for(int i=1;i<=k;i++){
        int x,y;
        scanf("%d%d",&x,&y);
        Union(fatherRoad,x,y);
    }
    for(int i=1;i<=l;i++){
        int x,y;
        scanf("%d%d",&x,&y);
        Union(fatherRail,x,y);
    }

    for(int i=1;i<=n;i++){
        Find(fatherRoad,i);
        Find(fatherRail,i);
    }
    map<pair<int,int>,int> mp;
    for(int i=1;i<=n;i++)
        mp[make_pair(fatherRoad[i],fatherRail[i])]++;
    for(int i=1;i<=n;i++)
        printf("%d\n",mp[make_pair(fatherRoad[i],fatherRail[i])]);
    return 0;
}