天天看點

hdu 5417 RGCDQ 2015多校聯合訓練賽 RGCDQ

RGCDQ

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1283    Accepted Submission(s): 562

Problem Description Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know  maxGCD(F(i),F(j))   (L≤i<j≤R)  

Input There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.

In the next T lines, each line contains L, R which is mentioned above.

All input items are integers.

1<= T <= 1000000

2<=L < R<=1000000

Output For each query,output the answer in a single line. 

See the sample for more details.

Sample Input

2
2 3
3 5
        

Sample Output

1
1
        

Source 2015 Multi-University Training Contest 3  

每個數字最多7個質因數,數量全部預處理。然後看l,r中有幾個數字有7,6.。。。1個質因子的,>= 2的就是一個gcd取最大值

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;

int pri[1000001];
int num[1000001];
int sum[1000001][10];
int inf = 1000000;
void init(){
    int ans = 0;
    memset(num,0,sizeof(num));
    for(int i = 2;i <= 1000000; i++){
        if(num[i] == 0){
            for(int j = i;j <= 1000000; j+=i)
                num[j] ++;
        }
    }
    memset(sum,0,sizeof(sum));
    for(int i = 1;i <= inf ;i++){
        for(int j = 1; j <= 7; j++)
            sum[i][j] = sum[i-1][j];
        sum[i][num[i]]++;
    }
}

int main(){
    int t,l,r;
    init();
    int s[10];
    while(scanf("%d",&t)!=EOF){
        while(t--){
            scanf("%d%d",&l,&r);
            for(int i = 1;i <= 7; i++)
                s[i] = sum[r][i] - sum[l-1][i];
            int ans = 1;
            for(int i = 7;i >= 1; i--){
                if(i == 2 && s[2] + s[4] + s[6] > 1)
                    ans = max(ans,2);
                else if(i == 3 && s[3] + s[6] > 1)
                    ans = max(ans,3);
                else if(s[i] > 1)
                    ans = max(ans,i);
            }
            printf("%d\n",ans);
        }
    }
    return 0;

}
           

繼續閱讀