天天看點

1020. Tree TraversalsTree Traversals

Tree Traversals

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
           

Sample Output:

4 1 6 3 5 7 2
           

題意

給定一棵二叉樹的後序周遊序列和中序周遊序列,要求輸出該二叉樹的層序周遊序列。

思路

由後序序列和中序序列可唯一确定一棵二叉樹,其實作步驟可參考 《先序中序後序求二叉樹》。

層序周遊的主要步驟如下:

  1. 根結點root入隊;
  2. 取出隊首結點并通路;
  3. 如果左孩子非空,則将其入隊;
  4. 如果右孩子非空,則将其入隊;
  5. 重複2-4,直到隊列為空。

代碼實作

#include <cstdio>
#include <queue>
using namespace std;

const int maxn = 31;
int post[maxn];
int in[maxn];

struct node
{
    int data;
    node* lchild;
    node* rchild;
};

node* create(int postL, int postR, int inL, int inR)    // 由後序和中序重建二叉樹
{
    if (postL > postR)
        return NULL;

    node* root = new node;
    root->data = post[postR];   // 後序序列最後一個元素即為根節點

    int k;
    for (k = inL; k <= inR; k++)    // 找到 中序序列中的根節點
        if (in[k] == post[postR])
            break;
    int numLeft = k - inL;      // 确定左子樹個數

    root->lchild = create(postL, postL + numLeft - 1, inL, k - 1);   // 遞歸處理左子樹
    root->rchild = create(postL + numLeft, postR - 1, k + 1, inR);   // 遞歸處理右子樹

    return root;
}

void levelOrder(node* root)     // 層序周遊
{
    queue<node*> q;
    bool flag = true;       // 控制空格輸出

    q.push(root);
    while (!q.empty())
    {
        node* top = q.front();
        q.pop();
        if (flag)
            flag = false;
        else
            printf(" ");
        printf("%d", top->data);


        if (top->lchild != NULL)
            q.push(top->lchild);    // 非空左孩子入隊
        if (top->rchild != NULL)
            q.push(top->rchild);    // 非空右孩子入隊
    }
}

int main()
{
    int n;

    scanf("%d", &n);
    for (int i = 0; i < n; i++)
        scanf("%d", &post[i]);
    for (int i = 0; i < n; i++)
        scanf("%d", &in[i]);

    node* root = create(0, n - 1, 0, n - 1);
    levelOrder(root);

    return 0;
}
           

繼續閱讀