An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
沒了解題意
說白就是pop代表的中序排列,push代表先序排列
輸出後序
就是已知中序和先序建立二叉樹,輸出後序
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
#include<map>
#include<set>
#include<stack>
using namespace std;
typedef struct tree{
int num;
struct tree *right;
struct tree *left;
}tree,*linktree;
linktree creat(int qian[],int zhong[],int n){
if(n<=0) return NULL;
linktree tre=new tree();
tre->num=qian[0];
int index=0;
for(int i=0;i<n;i++){
if(zhong[i]==qian[0]){
index=i;
break;
}
}
tre->left=creat(qian+1,zhong,index);
tre->right=creat(qian+index+1,zhong+index+1,n-index-1);
return tre;
}
int out[100],f=0;
void houprint(linktree head){
if(head){
houprint(head->left);
houprint(head->right);
out[f++]=head->num;
}
}
int main(){
int n;
cin>>n;
stack<int> sta;
int zhong[100],qian[100];
int cnt1=0,cnt2=0;
for(int i=0;i<2*n;i++){
char s[10];
scanf("%s",s);
if(s[1]=='u'){
int num;
cin>>num;
sta.push(num);
qian[cnt2++]=num;
}
else{
zhong[cnt1++]=sta.top();
sta.pop();
}
}
linktree head=creat(qian,zhong,n);
houprint(head);
printf("%d",out[0]);
for(int i=1;i<n;i++) printf(" %d",out[i]);
return 0;
}