天天看點

HDOJ 1025 Constructing Roads In JGShining's Kingdom (DP)

Constructing Roads In JGShining's Kingdom

Description

JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines. 

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one. 

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads. 

For example, the roads in Figure I are forbidden. 

In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^ 

Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file. 

Output

For each test case, output the result in the form of sample. 

You should tell JGShining what's the maximal number of road(s) can be built. 

Sample Input

2

1 2

2 1

3

1 2

2 3

3 1

Sample Output

Case 1:My king, at most 1 road can be built.

Case 2:My king, at most 2 roads can be built.

這裡分析樣例是就是叫你求出對于rich城市數組關于poor城市數組的最長遞增子序列,但一般方法寫會TLE....

于是用了網上看的另一種時間複雜度為O(n*logn)的寫法

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
#define N  500000
int b[N],dp[N];

int  find(int x,int l,int r)
{
    while(l<r)
    {
    int mid=(l+r)>>1;
    if(x<=dp[mid]) r=mid;
    else  l=mid+1;
    }
    return l;
}
int main()
{
    int i,n,j,kase=0,a,aa;
    while(scanf("%d",&n)!=EOF)
    {
        memset(b,0,sizeof(b));
        for(i=1;i<=n;i++)
        {
            scanf("%d %d",&a,&aa);
            b[a]=aa;
        }
        dp[1]=b[1];
        j=1;
        for(i=2;i<=n;i++)
        {
            if(b[i]>dp[j])  {
                j++;
            dp[j]=b[i];
            }
            else {
            int x=find(b[i],1,j);
            dp[x]=b[i];
            }
        }
        
        printf("Case %d:\n",++kase);
        if(j>1)
        printf("My king, at most %d roads can be built.\n\n",j);
        else 
       printf("My king, at most %d road can be built.\n\n",j);
    }
    return 0;
}