天天看點

POJ 2253 Frogger--最短路徑(dijstra、floyd)

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 57245 Accepted: 17989

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0
      

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
      

題解:青蛙要從石頭1通過各種路徑跳到石頭2,求青蛙跳躍的所有路徑中兩個石頭間的最長路徑選擇最短的一條路徑。例如(17,4)->(19,4)路徑中兩石頭間的最長路徑為2,(17,4)->(18,5)->(19,4)路徑中兩石頭間的最長路徑為1.414,選擇其中最短的一條路徑即為1.414。

dijstra:(變形)

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#define inf 1<<29
using namespace std;
double a[1005][1005];//無向帶權圖的鄰接矩陣存儲
int b[1005][2];
double dist[1005];//存儲最短路徑數組
int pre[1005];//儲存目前路徑前一個點的編号
int s[1005];//标記是否已存入pre數組
int n;
void dijkstra(int v)
{
    for(int i=0;i<n;i++)//dist數組初始化
    {
        if(i!=v)dist[i]=a[v][i];
        s[i]=0;
    }
    s[v]=1;
    pre[v]=0;
    dist[v]=0;
    for(int i=0;i<n;i++)//求v到所有點的最短路徑
    {
        int minset=inf,u=v;
        for(int j=0;j<n;j++)//求與pre數組最後一個點相連接配接的路徑中的最短路徑
            if(!s[j]&&dist[j]<minset)
        {
            u=j;
            minset=dist[u];
        }
        s[u]=1;
        for(int j=0;j<n;j++)//求得i到j點的最長路徑中的最短路徑
        {
            dist[j]=min(dist[j],max(dist[u],a[u][j]));
        }
    }
}
int main()
{
    int i,j,x,y,r=0;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
    {
        if(i==j)a[i][i]=0;
        else a[i][j]=a[j][i]=inf;
    }
    for(int i=0;i<n;i++)
    {
        scanf("%d%d",&b[i][0],&b[i][1]);
    }
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
         {
             if(i==j)a[i][j]=0;
             else a[i][j]=a[j][i]=sqrt(double(b[j][0]-b[i][0])*(b[j][0]-b[i][0])+double(b[j][1]-b[i][1])*(b[j][1]-b[i][1]));
         }
    }
    dijkstra(0);
    printf("Scenario #%d\n",++r);
    printf("Frog Distance = %.3lf\n",dist[1]);
    printf("\n");
    }
}
           

Floyd:(變形)

#include <iostream>
#include <math.h>
#include <algorithm>
#include <string.h>
#include <stdio.h>
using namespace std;
int n;
const int maxn=1005;
double dist[maxn][maxn];
int x[maxn],y[maxn];
void floyd()
{
    for(int k=0;k<n;k++)
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
            dist[i][j]=min(dist[i][j],max(dist[i][k],dist[k][j]));
}
int main()
{
    int cont=0;
    while(cin>>n,n)
    {
        cont++;
        memset(dist,0,sizeof(dist));
        for(int i=0;i<n;i++)
        {
            cin>>x[i]>>y[i];
        }
        for(int i=0;i<n;i++)
            for(int j=i+1;j<n;j++)
            dist[i][j]=dist[j][i]=sqrt(double(x[i]-x[j])*(x[i]-x[j])+double(y[i]-y[j])*(y[i]-y[j]));
            floyd();
        printf("Scenario #%d\n",cont);
        printf("Frog Distance = %.3lf\n",dist[0][1]);
        printf("\n");
    }
}
           

繼續閱讀