天天看點

hdu 1796HDU 1796

HDU 1796

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12255 Accepted Submission(s): 3665

Problem Description

Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input

There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output

For each case, output the number.

Sample Input

12 2

2 3

Sample Output

7

先考慮隻有一個數的情況,則小于n且能被該數p整除的數有(n-1)/p;當m集合裡面的數位兩個時,則每個數單獨整除小于n的數的個數為(n-1)/p1,(n-1)/p2,兩個加起來還包括了p1和p2的最小公倍數能整除的個數,故還要減去(n-1)/lcm(p1,p2),推廣到n,則明顯為容斥原理.

附上AC代碼:

注意細節

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>

using namespace std;

int n, m, cnt;
long long ans, a[20];

long long gcd(long long a, long long b)
{
    return b == 0 ? a : gcd(b,a%b);
}
//cur表示目前的數
//lcm表示最小公倍數
//id表示選了幾個數,奇數則加,偶數則減
void dfs(int cur, long long lcm, int id)
{
    lcm = a[cur]/gcd(a[cur],lcm)*lcm;
    if(id&1)
        ans += (n-1)/lcm;
    else ans -= (n-1)/lcm;
    for(int i = cur + 1; i < cnt; i++)
    {
        dfs(i,lcm,id+1);
    }
}
int main()
{
    while(~scanf("%d%d", &n, &m))
    {
        cnt = 0;
        for(int i = 0; i < m; ++i)
        {
            int x;
            scanf("%d", &x);
            if(x!=0) a[cnt++]=x; 		//注意除數不能為零
        }
        ans = 0;
        for(int i = 0; i < cnt; ++i)
        {
            dfs(i,a[i],1);
        }
        cout << ans << endl;
    }
    return 0;
}