天天看點

hdu 3746 Cyclic Nacklace(KMP 最短循環節) Cyclic Nacklace

1、http://acm.hdu.edu.cn/showproblem.php?pid=3746

2、題目大意:

給定一個字元串T, 在T後面添加x個字元串(讓x最小),使得新字元串由字首字串至少循環兩次構成的。

例如,

abca,  隻需要再添加2個字母bc, 形成abcabc,就變成了由abc循環兩次構成的。

對于長度為len的字元串,假設已經夠造完了next數組,那麼len-next[len]就是這個字元串的最小循環節。

如果正好len%(len-next[len])==0就說明正好組成完成的循環。

否則,說明還需要再添加幾個字母才能補全。

需要補的個數是循環個數len-next[len]-f[len]%(len-next[len]).

f[len]%(len-next[len])表示在最後一個循環節中已經構造了這麼多個數。

3、題目:

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1598    Accepted Submission(s): 690

Problem Description CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

hdu 3746 Cyclic Nacklace(KMP 最短循環節) Cyclic Nacklace

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.

CC is satisfied with his ideas and ask you for help.  

Input The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.

Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).  

Output For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.  

Sample Input

3
aaa
abca
abcde
        

Sample Output

0
2
5
        

Author possessor WC  

Source HDU 3rd “Vegetable-Birds Cup” Programming Open Contest  

4、代碼:

#include<stdio.h>
#include<string.h>
char str[100005];
int f[100005];
void getFail(char *p, int *f)
{
    int m=strlen(p);
    f[0]=f[1]=0;
    for(int i=1; i<m; ++i)
    {
        int j=f[i];
        while(j && p[i]!=p[j])j=f[j];
        f[i+1] = p[i]==p[j]?1+j:0;
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        //memset(str,0,sizeof(str));
        scanf("%s",str);
        getFail(str,f);
        int len=strlen(str);
        if(f[len]&&len%(len-f[len])==0)
        printf("0\n");
        else
        {
            printf("%d\n",(len-f[len])-f[len]%(len-f[len]));
        }
    }
    return 0;
}