天天看點

UVaOJ657---The die is cast 657 - The die is cast Time limit: 3.000 seconds

657 - The die is cast

Time limit: 3.000 seconds

InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty popular among their potential customers. Be it Monopoly, ludo or backgammon, most of these games involve throwing dice at some stage of the game.

Of course, it would be unreasonable if players were allowed to throw their dice and then enter the result into the computer, since cheating would be way to easy. So, instead, InterGames has decided to supply their users with a camera that takes a picture of the thrown dice, analyzes the picture and then transmits the outcome of the throw automatically.

For this they desperately need a program that, given an image containing several dice, determines the numbers of dots on the dice.

We make the following assumptions about the input images. The images contain only three dif- ferent pixel values: for the background, the dice and the dots on the dice. We consider two pixels connected if they share an edge - meeting at a corner is not enough. In the figure, pixels A and B are connected, but B and C are not.

UVaOJ657---The die is cast 657 - The die is cast Time limit: 3.000 seconds

A set S of pixels is connected if for every pair (a,b) of pixels in S, there is a sequence 

UVaOJ657---The die is cast 657 - The die is cast Time limit: 3.000 seconds

in S such that a = a1 and b = ak , and ai and ai+1 are connected for 

UVaOJ657---The die is cast 657 - The die is cast Time limit: 3.000 seconds

.

We consider all maximally connected sets consisting solely of non-background pixels to be dice. `Maximally connected' means that you cannot add any other non-background pixels to the set without making it dis-connected. Likewise we consider every maximal connected set of dot pixels to form a dot.

Input

The input consists of pictures of several dice throws. Each picture description starts with a line containing two numbers w and h, the width and height of the picture, respectively. These values satisfy

UVaOJ657---The die is cast 657 - The die is cast Time limit: 3.000 seconds

.

The following h lines contain w characters each. The characters can be: ``.'' for a background pixel, ``*'' for a pixel of a die, and ``X'' for a pixel of a die's dot.

Dice may have different sizes and not be entirely square due to optical distortion. The picture will contain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.

The input is terminated by a picture starting with w = h = 0, which should not be processed.

Output

For each throw of dice, first output its number. Then output the number of dots on the dice in the picture, sorted in increasing order.

Print a blank line after each test case.

Sample Input

30 15
..............................
..............................
...............*..............
...*****......****............
...*X***.....**X***...........
...*****....***X**............
...***X*.....****.............
...*****.......*..............
..............................
........***........******.....
.......**X****.....*X**X*.....
......*******......******.....
.....****X**.......*X**X*.....
........***........******.....
..............................
0 0
      

Sample Output

Throw 1
1 2 2 4
      

Miguel Revilla 

2000-05-22

#include <iostream>
#include <algorithm>
#include <queue>
#include <cstdio>
#include <cstring>
using namespace std;

#define N 60
struct node
{
   int x, y;
};
queue<struct node> q;
char s[N][N];
int vis[N][N];
int w, h;
int dx[5] = {0, -1, 1, 0, 0}, dy[] = {0, 0, 0, -1, 1};
int ccount;

void input()
{
   memset(s, 0, sizeof(s));
   memset(vis, 0, sizeof(vis));

   for (int i =1; i <= h; i ++)
   {
      gets(s[i] + 1);
   }
   for (int i = 0; i <= h + 1; i ++)
   {
      vis[i][0] = vis[i][w + 1] = 1;
   }
   for (int i = 0; i <= w + 1; i ++)
   {
      vis[0][i] = vis[h + 1][i] = 1;
   }
}

void BFS(int i, int j)
{
   int xx, yy;
   struct node tmp, ttmp;
   while (! q.empty())
   {
      q.pop();
   }
   s[i][j] = '*';
   tmp.x = i;
   tmp.y = j;
   q.push(tmp);
   while (! q.empty())
   {
      tmp = q.front();
      q.pop();
      for (int k = 1; k <= 4; k ++)
      {
         xx = tmp.x + dx[k];
         yy = tmp.y + dy[k];
         if (! vis[xx][yy] && s[xx][yy] == 'X')
         {
            s[xx][yy] = '*';
            ttmp.x = xx;
            ttmp.y = yy;
            q.push(ttmp);
         }
      }
   }

   return;
}

void DFS(int i, int j)
{
   int xx, yy;

   if (s[i][j] == 'X')
   {
      ccount ++;
      BFS(i, j);
   }
   vis[i][j] = 1;
   for (int k = 1; k <= 4; k ++)
   {
      xx = i + dx[k];
      yy = j + dy[k];
      if (!vis[xx][yy] && (s[xx][yy] == '*' || s[xx][yy] == 'X'))
      {
         DFS(xx, yy);
      }
   }

   return;
}

int main()
{
    int T = 0, c, num[N * N];
    while (cin>>w>>h)
    {
       getchar();
       T ++;
       if (w == 0 && h == 0)
       {
          break;
       }
       input();
       c = 0;
       for (int i = 1; i <= h; i ++)
       {
          for (int j = 1; j <= w; j ++)
          {
             if (((vis[i][j] && s[i][j] == 'X') || s[i][j] == '*'))
             {
                ccount = 0;
                DFS(i, j);
                if (ccount > 0 && ccount <= 6)
                {
                   num[c ++] = ccount;
                }
             }
          }
       }
       sort(num, num + c);
       cout<<"Throw "<<T<<endl;
       cout<<num[0];
       for (int i = 1; i < c; i ++)
       {
          cout<<" "<<num[i];
       }
       cout<<endl<<endl;
    }
    return 0;
}
           

繼續閱讀