天天看點

poj2182 Lost Cows-線段樹

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1…N. In a spectacular display of poor judgment, they visited the neighborhood ‘watering hole’ and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he’s not very good at observing problems. Instead of writing down each cow’s brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.

Input

Line 1: A single integer, N

Lines 2…N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.
           

Output

Lines 1…N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.
           

Sample Input

5

1

2

1

Sample Output

2

4

5

3

1

題目大意:

有編号1-n的n個數字,2<=n<=8000,亂序排列,排序是未知的。對于每個位置的數字,知道排在它前面比它小的數字有多少個。求這個亂序數列的順序。

解題關鍵:

在剩下的編号中,第pre[n]+1個數字就是ans[n]

代碼如下:

#include <iostream>
using namespace std;
const int N = 10010;
int ans[N];
int pre[N];

struct node {
	int l, r;
	int len;
} tree[4 * N];

void build(int l, int r, int u) {
	tree[u].l = l;
	tree[u].r = r;
	if (l == r) {
		tree[u].len = l - r + 1;
//		cout << u << " - " << tree[u].len << endl;
		return;
	}
	int mid = (l + r) >> 1;
	build(l, mid, 2 * u);
	build(mid + 1, r, 2 * u + 1);
	tree[u].len = tree[2 * u].len + tree[2 * u + 1].len;
//	cout << u << " - " << tree[u].len << endl;
}

int query(int u, int num) {
	tree[u].len--;
	if (tree[u].l == tree[u].r)
		return tree[u].l;
	if (tree[2 * u].len < num) {
		return query(2 * u + 1, num - tree[2 * u].len);
	}
	if (tree[2 * u].len >= num) {
		return query(2 * u, num);
	}
}

int main() {
	int n, i;
	cin >> n;
	pre[1] = 0;
	for (int i = 2; i <= n; i++)
		cin >> pre[i];
	build(1, n, 1);
//	for (int i = 1; i <= n; i++)
//		cout << tree[i].len << " ";
//	cout << endl;
	for (int i = n; i >= 1; i--) {
		ans[i] = query(1, pre[i] + 1);
	}
	for (int i = 1; i <= n; i++)
		cout << ans[i] << endl;
//	cout << endl;
	return 0;
}