天天看點

POJ2182:Lost Cows(單點)

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.

Input

* Line 1: A single integer, N

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0
      

Sample Output

2
4
5
3
1
      
題意:給出的數字表示從第2到第n隻牛左邊有幾個比它序号小的牛,要求每個位置的牛的編号是多少      
思路:這道題其實和POJ2828有點相似,因為最後一個牛的編号是可以确定的,必定是k+1,然後我們可以根據這個規律進行逆推,線段樹存儲的是每個區間内還有幾個空位      
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int n,ans[1000000],s[1000000];

struct node
{
    int l,r,n;
} a[1000000];

void init(int l,int r,int i)
{
    a[i].l = l;
    a[i].r = r;
    a[i].n = r-l+1;//該區間内能放的數字個數
    if(l!=r)
    {
        int mid = (l+r)/2;
        init(l,mid,2*i);
        init(mid+1,r,2*i+1);
    }
}

int insert(int i,int x)
{
    a[i].n--;
    if(a[i].l == a[i].r)
        return a[i].l;
    if(a[2*i].n>=x)//左子樹的數字足夠,則走左子樹
        insert(2*i,x);
    else//否則走右子樹,并且将子樹視為新樹,編号從1開始
        insert(2*i+1,x-a[2*i].n);
}

int main()
{
    int i,j;
    while(~scanf("%d",&n))
    {
        s[1] = 0;
        for(i = 2; i<=n; i++)
            scanf("%d",&s[i]);
        init(1,n,1);
        for(i = n; i>=1; i--)//逆推
            ans[i] = insert(1,s[i]+1);
        for(i = 1; i<=n; i++)
            printf("%d\n",ans[i]);
    }

    return 0;
}