天天看點

BFS--躲避某一時間掉下來的隕石

Meteor Shower

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 32119 Accepted: 8254

Description

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (Xi, Yi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

* Line 1: A single integer: M

* Lines 2..M+1: Line i+1 contains three space-separated integers: Xi, Yi, and Ti

Output

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input

4

0 0 2

2 1 2

1 1 2

0 3 5

Sample Output

5

#include<cstdio>
#include<iostream>
#include<queue>
using namespace std;

const int MAX_X = 310;
const int MAX_Y = 310;

const int INF = 100000000;

const int dir[4][2] = { 1,0,-1,0,0,1,0,-1 };

int Map[MAX_X][MAX_Y];
bool Visited[MAX_X][MAX_Y];

int M;

struct Meteor {
  int x, y;
  int time;
}StartPoint;

inline int dfs(int x, int y) {
  StartPoint.x = x,StartPoint.y = y,StartPoint.time = 0;
  Visited[x][y] = true;
  queue<Meteor> q;
  q.push(StartPoint);
  while (!q.empty()) {
    Meteor now = q.front();
    q.pop();
    if (Map[now.x][now.y] == INF) {
      return now.time;
    }
    for (int i = 0; i < 4; i++) {
      int tmpx = now.x + dir[i][0];
      int tmpy = now.y + dir[i][1];
      int tmpt = now.time + 1;
      if (tmpx >= 0 && tmpy >= 0 && !Visited[tmpx][tmpy] && tmpt < Map[tmpx][tmpy]) {
        StartPoint.x = tmpx, StartPoint.y = tmpy, StartPoint.time = tmpt;
        q.push(StartPoint);
        Visited[tmpx][tmpy] = true;
      }
    }
  }
  return -1;
}

int main() {
  memset(Visited, false, sizeof(Visited));
  for (int i = 0; i < MAX_X; i++) {
    for (int j = 0; j < MAX_Y; j++) {
      Map[i][j] = INF;
    }
  }
  scanf("%d", &M);
  int X, Y, T;
  for (int i = 0; i < M; i++) {
    scanf("%d%d%d", &X, &Y, &T);
    Map[X][Y] = min(Map[X][Y], T);
    for (int i = 0; i < 4; i++) {
      int tmpx = X + dir[i][0];
      int tmpy = Y + dir[i][1];
      if (tmpx >= 0 && tmpy >= 0) {
        Map[tmpx][tmpy] = min(Map[tmpx][tmpy], T);
      }    
    }
  }
  int Result = dfs(0, 0);
  printf("%d\n", Result);
  return 0;
}