天天看點

hdu6124 Euler theorem -多校聯盟7Euler theorem

Euler theorem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)

Total Submission(s): 383    Accepted Submission(s): 311

Problem Description HazelFan is given two positive integers a,b , and he wants to calculate amodb . But now he forgets the value of b and only remember the value of a , please tell him the number of different possible results.  

Input The first line contains a positive integer T(1≤T≤5) , denoting the number of test cases.

For each test case:

A single line contains a positive integer a(1≤a≤109) .  

Output For each test case:

A single line contains a nonnegative integer, denoting the answer.

Sample Input

2
1
3
        

Sample Output

2
3
        
/*
題意
a對任意一個數取餘能得到幾種不同的結果

題解
從a/2+1開始到a對a取餘數結果都不一樣,加上>a時候的情況。共(a+1)/2+1種
*/
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
 using namespace std;

const int maxn = 1e7+10;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        int a;
        scanf("%d",&a);
        printf("%d\n",(a+1)/2+1);
    }
    return 0;
}