天天看點

HDU 1157 Who's in the MiddleWho's in the Middle

http://acm.hdu.edu.cn/showproblem.php?pid=1157

Who's in the Middle

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4274 Accepted Submission(s): 2152

Problem Description FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input * Line 1: A single integer N

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output * Line 1: A single integer that is the median milk output.

Sample Input 5 2 4 1 3 5

Sample Output 3 Hint INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.

Source USACO 2004 November

Recommend mcqsmall

分析:排個序,輸出中間的數即可。

代碼如下:

#include<stdio.h>

#include<stdlib.h>

int cmd(const void *a,const void *b)

{

 return *(int *)a-*(int *)b;

}

int main()

{

 int T;

 int i,j;

 int ans[10001];

 while(scanf("%d",&T)==1)

 {

  for(i=0;i<T;i++)

    scanf("%d",&ans[i]);

        qsort(ans,T,sizeof(ans[0]),cmd);

        printf("%d\n",ans[T/2]);

 }

 return 0;

}

繼續閱讀