天天看點

7.22 第二場 I love stringI love string

I love string

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)

Total Submission(s): 290 Accepted Submission(s): 166

Problem Description

Mr X likes to play string games.

Mr X has an operation sequence. This operation sequence can be written as a string. For each operation, the next character of the operation sequence can be inserted before or after the current string. For example, my operation sequence is “aabac”, suppose the sequence obtained after the first four operations is “baaa”, then after the last operation, the string may become “baaac” or “cbaaa”. It can be seen that there is only one operation method for the first operation. For other operations, there are only two methods of operation.

For each operation method, there will be a score. The smaller the lexicographic order of the final string, the higher the final score.

Then, for a given operation sequence, how many operation methods can get the maximum score.

The two operation methods are different. If and only if there is a certain operation (not the first operation), one operation will be inserted before the current string, and the other operation will be inserted after the current string.

Input

Enter a positive integer T (T≤10) on the first line to represent the number of test cases.

For each test case:

the first line contains a integer n (1≤n≤100000) to represent the length of the string.

the second line contains a string of lowercase letters , which represents the sequence of operations.

Output

For each test case, output a line of a positive integer to represent the number of schemes, and the answer is modulo 1000000007

Sample Input

1
5
abcde
           

Sample Output

大概題意

一行字元,有頭插和尾插兩種操作插入結果字元串中,要使結果字元串字典序最小,求操作種數。

思路

當結果字元串中隻有同種字元時,頭插尾插結果相同,而在保持字典序最小的過程中,當且僅當結果字元串第一個字元與最後一個字元相同時,結果字元串中隻有同種字元

代碼

//
// Created by Black on 2021/7/22.
//
#include <iostream>
#include <cstring>
#include <vector>

using namespace std;
const int N = 100010;
const int MOD = 1000000007;
int T, n;
char s[N];

int main() {
    cin >> T;
    while (T--) {
        vector<char> c;
        int res = 1;
        cin >> n;
        cin >> s;
        for (int i = 0; i < n; ++i) {
            if (c.empty())c.push_back(s[i]);
            else {
                if (c[0] >= s[i]) {
                    c.insert(c.begin(), s[i]);
                } else {
                    c.push_back(s[i]);
                }
                if (c[0] == c[c.size() - 1]) {
                    res *= 2;
                    res = res % MOD;
                }
            }
        }
        cout << res << endl;

    }
    return 0;
}

           

繼續閱讀