天天看點

hdoj 2612 <雙點bfs就最小相交時間>

Find a way

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 10300    Accepted Submission(s): 3357

Problem Description

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.

Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 

Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input

The input contains multiple test cases.

Each test case include, first two integers n, m. (2<=n,m<=200). 

Next n lines, each line included m character.

‘Y’ express yifenfei initial position.

‘M’    express Merceki initial position.

‘#’ forbid road;

‘.’ Road.

‘@’ KCF

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

4 4

Y.#@

....

.#..

@..M

4 4

Y.#@

....

.#..

@#.M

5 5

Y..@.

.#...

.#...

@..M.

#...#

Sample Output

66

88

66

Author

yifenfei

Source

​​奮鬥的年代​​

兩人相遇于特定條件點時可以兩人分别bfs--并記錄到特定點的距離---

然後求出距離之和的最小值--

(開始想狀壓----發現條件找不到--(次數壓到2求不出正确值---且有特殊情況--壓多了時間不如兩次bfs--))

歡迎用狀壓的大神來此分享經驗---

#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
#define MA 202
int n,m;
char ma[MA][MA];
bool fafe[MA][MA];
int bu[MA][MA][2];
int xx[4]={0,0,1,-1};
int yy[4]={1,-1,0,0};
struct node{
    int x,y,step;
}now,qian;
void bfs(int kxx,int kyy,int kk)
{
    now.x=kxx;now.y=kyy;
    now.step=0;
    fafe[kxx][kyy]=false;
    queue<node> Q;
    Q.push(now);
    while (!Q.empty())
    {
        now=Q.front();
        Q.pop();
        if (ma[now.x][now.y]=='@')
        {
            bu[now.x][now.y][kk]=now.step;
        }
        for (int i=0;i<4;i++)
        {
            int kx=now.x+xx[i];
            int ky=now.y+yy[i];
            if (kx>=0&&ky>=0&&kx<n&&ky<m&&ma[kx][ky]!='#'&&fafe[kx][ky])
            {
                fafe[kx][ky]=false;
                qian.step=now.step+1;
                qian.x=kx;qian.y=ky;
                Q.push(qian);
            }
        }
    }
}
int main()
{
    int jn,jm,kn,km;
    while (~scanf("%d%d",&n,&m))
    {
        for (int i=0;i<n;i++)
        {
            scanf("%s",ma[i]);
            for (int j=0;j<m;j++)
            {
                if (ma[i][j]=='Y')
                {
                    kn=i;km=j;
                }
                if (ma[i][j]=='M')
                {
                    jn=i;jm=j;
                }
            }
        }
        memset(bu,0x3f3f3f,sizeof(bu));
        memset(fafe,true,sizeof(fafe));
        bfs(kn,km,0);
        memset(fafe,true,sizeof(fafe));
        bfs(jn,jm,1);
        int mi=99999999;
        for (int i=0;i<n;i++)
        for (int j=0;j<m;j++)
        if (ma[i][j]=='@')
        {
            mi=min(mi,bu[i][j][0]+bu[i][j][1]);
        }
        printf("%d\n",mi*11);
    }
    return 0;
}