天天看點

POJ2352 Stars 樹狀數組 + 裸

1)

為了避免出現0,保證從1開始,是以每次輸入x以後,都先x++;

觀察得知輸入的資料因為有y 、x一次遞增的規律,是以利用這一特性,隻比較x。

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;
const int maxn=32010;
int star[maxn];
int level[maxn];
int Init(int x){
        return x&(-x);//2^k,k是x以二進制形式時末尾0的個數
}
int Sum(int x){
       int res=0;
        while(x>0){
                res+=star[x];
                x-=Init(x);
       }
       return res;
}
void Add(int x){
        while(x<=maxn){
                star[x]++;
                x+=Init(x);
        }
        return ;
}
int main()
{
        int n;
        while(~scanf("%d",&n)){
                memset(star,0,sizeof(star));
                memset(level,0,sizeof(level));
                int x;
                int y;
                for(int i=1;i<=n;i++){
                        scanf("%d%d",&x,&y);
                        x++;//保證從1開始,避免出現0
                        level[Sum(x)]++;
                        Add(x);//先計數,後加入,保證自身不是自己的子星星,而在自己正下方的點又能被包括進去。
                }
                for(int i=0;i<=n-1;i++){
                        cout<<level[i]<<endl;
                }
        }

        return 0;
}
           

2)

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

POJ2352 Stars 樹狀數組 + 裸

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5      

Sample Output

1
2
1
1
0      

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.