天天看點

Super Jumping! Jumping! Jumping!(DP 最長不下降子序列 )超詳細題解

目錄

  • ​​1.題目​​
  • ​​2.題意​​
  • ​​3.解題思路​​
  • ​​4.代碼​​

1.題目

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盤)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.

A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0      

Sample Output

4
10
3      

2.題意

3.解題思路

4.代碼

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 1e4 + 10;
int dp[maxn],a[maxn]; //dp[i]表示以a[i]結尾的最大遞增子序列值(非連續)
int main()
{
  int n;
  while (cin >> n)
  {
    memset(dp, 0, sizeof(dp));  每次初始化dp[i]數組
    if (n == 0) break;
    for (int i = 1; i <= n; i++)
    {
      cin >> a[i];
      dp[i] = a[i];   //邊界
    }
    int ans = -1;   ///記錄最大dp[i];
    for (int i = 1; i<= n; i++)
    {
      for (int j = 1; j < i; j++)
      {
        if (a[j] < a[i] && (dp[j] + a[i] > dp[i]))
        {
          dp[i]=dp[j]+a[i]; 狀态轉移方程,用于更新dp[i];
        }
      }
      ans = max(ans, dp[i]);
    }
    cout << ans << endl;
  }
  return 0;
}      

繼續閱讀