天天看點

HDU 1068 Girls and Boys 最大獨立集Girls and Boys

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 239 Accepted Submission(s): 159

Problem Description the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students

the description of each student, in the following format

student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...

or

student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.

For each given data set, the program should write to standard output a line containing the result.  

Output
Sample Input
7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0      
Sample Output
5
2      

Source 題目大意:

給出一些人互相認識,求一個最大的集合,裡面的人互不相識。

思路:

最大獨立集 = n - 單向圖最大比對/2

AC代碼:

#include"stdio.h"
#include"string.h"
#include"queue"
#include"vector"
#include<iostream>
using namespace std;
#define N 1505
#define max(a,b) (a>b?a:b)
#define min(a,b) (a<b?a:b)
const int inf=0x7fffffff;
int mark[N],n,t;
int link[N],head[N];
struct node
{
    int u,v,next;
}g[N*10];
void add(int u,int v)
{
    g[t].u=u;
    g[t].v=v;
    g[t].next=head[u];
    head[u]=t++;
}
int find(int u)
{
    int i,v;
    for(i=head[u];i!=-1;i=g[i].next)
    {
        v=g[i].v;
        if(!mark[v])
        {
            mark[v]=1;
            if(link[v]==-1||find(link[v]))
            {
                link[v]=u;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int i,u,q,v;
    while(scanf("%d",&n)!=-1)
    {
        memset(head,-1,sizeof(head));
        memset(link,-1,sizeof(link));
        t=0;
        for(i=0;i<n;i++)
        {
            scanf("%d: (%d)",&u,&q);
            while(q--)
            {
                scanf("%d",&v);
                add(u,v);
            }
        }
        int ans=0;
        for(i=0;i<n;i++)
        {
            memset(mark,0,sizeof(mark));
            ans+=find(i);
        }
        printf("%d\n",n-ans/2);
    }
    return 0;
}