Free DIY Tour
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5544 Accepted Submission(s): 1776
Problem Description
Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour.
The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number.
Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both
1 and
N+1), and its interesting point is always 0.
Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?
Input
The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.
Output
For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit.
Output a blank line between two cases.
Sample Input
2
3
0 70 90
4
1 2
1 3
2 4
3 4
3
0 90 70
4
1 2
1 3
2 4
3 4
Sample Output
CASE 1#
points : 90
circuit : 1->3->1
CASE 2#
points : 90
circuit : 1->2->1
Author
JGShining(極光炫影)
Source
杭州電子科技大學第三屆程式設計大賽
此題說是最短(長)路徑題,不如說是動态規劃+路徑判斷。
題意:給你一個有環的圖,結點之間有路徑,每個結點都有個興趣值,現在給你起點,找一條路徑再次回到起點,使經過的結點的興趣值總和最大,問最大的總和是多少并且輸出其路徑。
隻從題意的角度講,很像動态規劃裡面的最長公子序列(小編我就是這樣做的……),此題的資料也不是很強,是以我們還是采取Floyd算法吧
#include <cstdio>
#include <cstring>
#define maxn 1010
int map[maxn][maxn],v[maxn],pre[maxn],dp[maxn];
void out(int i)
{
if(i == 1)
{
printf("1");
return;
}
out(pre[i]);
printf("->%d",i);
}
int main()
{
int t,c=0;
scanf("%d",&t);
while(t--)
{
int n,i,j,m,end;
memset(v,0,sizeof(v));
memset(pre,0,sizeof(pre));
memset(map,0,sizeof(map));
memset(dp,0,sizeof(dp));
scanf("%d",&n);
for(i=1; i<=n; i++)
scanf("%d",&v[i]);
scanf("%d",&m);
while(m--)
{
int a,b;
scanf("%d%d",&a,&b);
map[a][b] = 1;
}
for(i=1; i<=n+1; i++)
{
for(j=1; j<i; j++)
{
if(map[j][i] && dp[i]<dp[j]+v[i])
{
dp[i] = dp[j]+v[i];
pre[i] = j;
}
}
}
printf("CASE %d#\n",++c);
printf("points : %d\n",dp[n+1]);
printf("circuit : ");
out(pre[n+1]);
printf("->1\n");
if(t) printf("\n");
}
return 0;
}