天天看點

【POJ 1195】Mobile phones【題目】【分析】【代碼】

【題目】

傳送門

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.

【POJ 1195】Mobile phones【題目】【分析】【代碼】

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024

Cell value V at any time: 0 <= V <= 32767

Update amount: -32768 <= A <= 32767

No of instructions in input: 3 <= U <= 60002

Maximum number of phones in the whole table: M= 2^30

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4

1 1 2 3

2 0 0 2 2

1 1 1 2

1 1 2 -1

2 1 1 2 3

3

Sample Output

3

4

【分析】

大緻題意:要求維護一種資料結構,使它能支援下列操作:

0 S:給出一個 S * S 的矩陣,初始為全部 0

1 X Y A:在坐标為(X,Y)的位置加上 A(注意下标是從(0,0)開始編号的)

2 L B R T:詢問矩陣的權值和,其中矩陣的左上角坐标為(L,B),右下角為(R,T)

3:結束整個程式

其實看懂這道題題意的話就知道這是一道裸的二維樹狀數組的模闆

唯一要注意的就是矩陣是以(0,0)開始編号的

然後就直接上代碼吧

【代碼】

#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 2005
#define lowbit(x) x&-x
using namespace std;
int n,tree[N][N];
void add(int x,int y,int k)
{
	int i,j;
	for(i=x;i<=n;i+=lowbit(i))
	  for(j=y;j<=n;j+=lowbit(j))
	    tree[i][j]+=k;
}
int sum(int x,int y)
{
	int i,j,ans=0;
	for(i=x;i;i-=lowbit(i))
	  for(j=y;j;j-=lowbit(j))
	    ans+=tree[i][j];
	return ans;
}
int main()
{
	int s,i,x,y,k,l;
	scanf("%d%d%d",&s,&n,&s);
	while(s!=3)
	{
		if(s==1)
		{
			scanf("%d%d%d",&x,&y,&k);
			add(x+1,y+1,k);
		}
		else
		{
			scanf("%d%d%d%d",&x,&y,&k,&l);
			printf("%d\n",sum(k+1,l+1)-sum(k+1,y)-sum(x,l+1)+sum(x,y));
		}
		scanf("%d",&s);
	}
	return 0;
}
                

繼續閱讀