天天看點

POJ 1528 Perfection(我的水題之路——因子之和)

Perfection

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8608 Accepted: 4136

Description

From the article Number Theory in the 1994 Microsoft Encarta: ``If a, b, c are integers such that a = bc, a is called a multiple of b or of c, and b or c is called a divisor or factor of a. If c is not 1/-1, b is called a proper divisor of a. Even integers, which include 0, are multiples of 2, for example, -4, 0, 2, 10; an odd integer is an integer that is not even, for example, -5, 1, 3, 9. A perfect number is a positive integer that is equal to the sum of all its positive, proper divisors; for example, 6, which equals 1 + 2 + 3, and 28, which equals 1 + 2 + 4 + 7 + 14, are perfect numbers. A positive number that is not perfect is imperfect and is deficient or abundant according to whether the sum of its positive, proper divisors is smaller or larger than the number itself. Thus, 9, with proper divisors 1, 3, is deficient; 12, with proper divisors 1, 2, 3, 4, 6, is abundant." 

Given a number, determine if it is perfect, abundant, or deficient. 

Input

A list of N positive integers (none greater than 60,000), with 1 <= N < 100. A 0 will mark the end of the list.

Output

The first line of output should read PERFECTION OUTPUT. The next N lines of output should list for each input integer whether it is perfect, deficient, or abundant, as shown in the example below. Format counts: the echoed integers should be right justified within the first 5 spaces of the output line, followed by two blank spaces, followed by the description of the integer. The final line of output should read END OF OUTPUT.

Sample Input

15 28 6 56 60000 22 496 0      

Sample Output

PERFECTION OUTPUT
   15  DEFICIENT
   28  PERFECT
    6  PERFECT
   56  ABUNDANT
60000  ABUNDANT
   22  DEFICIENT
  496  PERFECT
END OF OUTPUT      

Source

Mid-Atlantic 1996

對于每一個數,把它的所有除了本身以外的因子相加,如果之和大于它本身就認為這個數abundant,如果之和小于它本身就認為這個數deficient,如果之和等于它本身就認為這個數prefect,以0為結束,按照題中給出格式輸出。

因為這個是弱資料,題中給出隻有100組不到的資料,是以可以直接用暴力求解,對于每一個數,求其因子之和,判斷。

注意點: 1)如果是大資料,這道題不能用暴力,除非使用打表 2)數字和結果之間有兩個空格 3)考慮邊界資料1、2 4)如果一個數的兩個因子相同,隻取其中一個相加,如,9的因子隻有1、3.

代碼(1AC):

#include <cstdio>
#include <cstdlib>
#include <cmath>

char answer[][20] = {"PERFECT", "ABUNDANT", "DEFICIENT"};

int JudgeNum(int num){ // 0 perfect 1 abundant 2 deficient
    int i, j;
    int sum;

    if (num == 1){
        return 2;
    }
    else if (num == 2){
        return 2;
    }
    else if (num == 4){
        return 2;
    }
    sum = 1;
    for (i = 2; i <= sqrt(num); i++){
        if (num % i == 0){
            if (i < num / i){
                sum += i;
                sum += num / i;
            }
            else if (i == num / i){
                sum += i;
            }
           // printf("i: %d, sum: %d\n", i, sum);
        }
    }
    if (sum == num){
        return 0;
    }
    else if (sum < num){
        return 2;
    }
    else if (sum > num){
        return 1;
    }
}

int main(void){
    int num;

    printf("PERFECTION OUTPUT\n");
    while (scanf("%d", &num), num != 0){
        printf("%5d  %s\n", num, answer[JudgeNum(num)]);
    }
    printf("END OF OUTPUT\n");
    return 0;
}
           

繼續閱讀