天天看點

1047 Student List for Course (25 分) vector

1047 Student List for Course (25 分)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5      

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1      
#include<bits/stdc++.h>
using namespace std;

vector<string> ve[2510];
int n,k,c,id;
string name;
char na[10];

int main(){
//  freopen("in.txt","r",stdin);
  cin>>n>>k;
  while(n--){
    scanf("%s",na);name=na;
    scanf("%d",&c);
    while(c--){
      scanf("%d",&id);
      ve[id].push_back(name);
    }
  }
  for(int i=1;i<=k;i++){
    printf("%d %d\n",i,ve[i].size());
    sort(ve[i].begin(),ve[i].end());
    for(int j=0;j<ve[i].size();j++){
      printf("%s\n",ve[i][j].c_str());
    }
  }
  return 0;
}