天天看點

hide handkerchief HDU - 2104

F - hide handkerchief Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit  Status

Description

The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends. 

Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes . 

Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A. 

So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".

Input

There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.

Output

For each input case, you should only the result that Haha can find the handkerchief or not.

Sample Input

3 2
-1 -1      

Sample Output

YES      
題意:幾個人圍繞成一個圈丢手絹,一個人去找,他每次找下一個人的時候會隔m-1個人,問最後能否找到手絹,其實就是看能否全部周遊
 思路:一開始我就是開個簡單的數組然後循環周遊,并開個數組book标記那些找過了,然後周遊看是否有未被周遊的,送出後發現MLE。
看了别人的部落格才知道用最大公約數求解 如果兩個數的最大公約數不為1的話 他經過一定周期後一定會回到原來的位置而其他的位置還未通路過;
 看到别人部落格上的例子:容易了解,特附上      
舉個例子  :5 和 2 标号為1 2 3 4 5  先從1開始 依次為1~3~5~2~4~1 結束
 6 4 标号為1 2 3 4 5 6  1~5~3~1 後面就一直循環了 而 2 4 6 還沒有通路過
簡單的輾轉相除法求最大公約數      
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

int main()
{
    int n,m,flag;
    while(~scanf("%d %d",&n,&m))
    {
        flag=0;
        if(m==-1&&n==-1)
        {
            break;
        }
        if(m>n)
        {
            int temp=m;
            m=n;
            n=temp;
        }
        int r=n%m;
        while(r)
        {
            n=m;
            m=r;
            r=n%m;
        }
        if(m==1)
        {
            flag=1;
        }
        if(flag==1)
            printf("YES\n");
        else
            printf("POOR Haha\n");
    }
    return 0;
}