天天看點

pku 3468 A Simple Problem with Integers(線段樹)

A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 44296 Accepted: 12961
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.

The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.

Each of the next Q lines represents an operation.

"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.

"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
      

Sample Output

4
55
9
15      

Hint

The sums may exceed the range of 32-bit integers.

Source

POJ Monthly--2007.11.25, Yang Yi   題意:給定n個數,給一個區間所有數一同加d,或者查詢一個區間的和 題解:線段樹+lazy思想,開多個數組表示延遲标記,在add的時候隻改變mark标記數組,查詢的時候再改變線段樹的區間值,進而防止線段樹的效率退化成n  

#include<stdio.h>
#include<string.h>
__int64 a[100005],c[400500],mark[400500],n;
void init(int l,int r,int pos)
{
    int mid=(l+r)/2;
    mark[pos]=0;
    if(l==r){ c[pos]=a[l]; return; }
    init(l,mid,2*pos),init(mid+1,r,2*pos+1);
    c[pos]=c[2*pos]+c[2*pos+1];
}
__int64 ques(__int64 l,__int64 r,__int64 pos,__int64 templ,__int64 tempr)
{
    __int64 mid=(l+r)/2;
    if(templ==l&&r==tempr) return c[pos]+mark[pos]*(r-l+1);
    if(mark[pos]!=0)
    {
        mark[2*pos+1]+=mark[pos];
        mark[2*pos]+=mark[pos];
        c[pos]+=mark[pos]*(r-l+1),mark[pos]=0;
    }
    if(templ>mid) return ques(mid+1,r,2*pos+1,templ,tempr);
    else if(tempr<=mid) return ques(l,mid,2*pos,templ,tempr);
    else return ques(l,mid,2*pos,templ,mid)+ques(mid+1,r,2*pos+1,mid+1,tempr);
}
void add(__int64 l,__int64 r,__int64 pos,__int64 templ,__int64 tempr,__int64 val)
{
    __int64 mid=(l+r)/2;
    if(templ==l&&r==tempr){ mark[pos]+=val; return;}
    c[pos]+=val*(tempr-templ+1);
    if(templ>mid) add(mid+1,r,2*pos+1,templ,tempr,val);
    else if(tempr<=mid) add(l,mid,2*pos,templ,tempr,val);
    else add(mid+1,r,2*pos+1,mid+1,tempr,val),add(l,mid,2*pos,templ,mid,val);
}
int main()
{
    __int64 m,i,x,y,z;
    char ch;

    while(scanf("%I64d%I64d",&n,&m)>0)
    {
        for(i=1;i<=n;i++) scanf("%I64d",a+i);
        init(1,n,1);
        for(i=0;i<m;i++)
        {
            getchar();
            scanf("%c",&ch);
            if(ch=='Q')
            {
                scanf("%I64d%I64d",&x,&y);
                printf("%I64d\n",ques(1,n,1,x,y));
            }
            else
            {
                scanf("%I64d%I64d%I64d",&x,&y,&z);
                add(1,n,1,x,y,z);
            }
        }
    }

    return 0;
}
           

繼續閱讀