Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19646 Accepted Submission(s): 8793
Problem Description A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.

Input n (0 < n < 20).
Output The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
經典DFS題,這裡注意輸出格式就能AC了:
#include<iostream>
#include<cmath>
const int MAX=100;
int prim[MAX];
int chucun[MAX];
int mark[MAX];
int n;
int count;
using namespace std;
int main()
{
int i,p=1;
void DFS(int x);
bool prime(double x);
while(cin>>n)
{
cout<<"Case "<<p++<<':'<<endl;
chucun[0]=1;
memset(mark,0,sizeof(mark));
DFS(1);
cout<<endl;
}
}
bool prime(double x)
{
int i;
for(i=2;i<=sqrt(x);i++)
{
if(int(x)%i==0)
return false;
}
return true;
}
void DFS(int x)
{
if(x==n&&(prime(double(1+chucun[x-1]))))
{
for(int i=0;i<x;i++)
{
if(i==0)
cout<<chucun[i];
else
cout<<" "<<chucun[i];
}
cout<<endl;
}
else
{
for(int i=2;i<=n;i++)
{
if(mark[i]||!prime(double(chucun[x-1]+i)))
continue;
mark[i]=1;
chucun[x]=i;
DFS(x+1);
mark[i]=0;
}
}
}