天天看點

ACM-尼姆博弈之John——hdu1907 John

John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 2577    Accepted Submission(s): 1400

Problem Description Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

  Input The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:

1 <= T <= 474,

1 <= N <= 47,

1 <= Ai <= 4747

  Output Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

  Sample Input

2
3
3 5 1
1
1
        

  Sample Output

John
Brother
        

  Source Southeastern Europe 2007   題目:http://acm.hdu.edu.cn/showproblem.php?pid=1907

近期在看博弈系列,搞完了巴什博弈、威佐夫博弈,接下來就是這個尼姆博弈。 這一系列博弈類型可以概括為: 巴什博弈:從一堆石子中拿石子,一次拿1~m個。 威佐夫博弈:從兩堆石子中拿石子,方法①任選一堆石子拿k個石子(k≥1),方法②從兩堆石子中拿相同數量的石子(當然所拿的數要≥1) 尼姆博弈:從三堆石子中拿石子,每次任選一堆拿任意數目(≥1)的石子。 這些當然是誰先那光,誰獲勝。

尼姆博弈解法,和二進制有關。 反正我不知道他們怎麼推得,隻會用。o(╯□╰)o。。。 給出的數 用異或加起來,若等于0,則為奇異态(必勝态)。

這道題有些不一樣,如果John吃的是某個盒子最後一顆,那就判定John為敗。 是以,這道題分為兩種情況讨論: ①若所有堆的數量都為1。則根據奇偶來判斷誰勝。 ②其他情況,将所有資料異或起來,判斷是否為奇異态。

/**************************************
***************************************
*        Author:Tree                  *
*From :http://blog.csdn.net/lttree    *
* Title : John                        *
*Source: hdu 1907                     *
* Hint  : 尼姆博弈                   *
***************************************
**************************************/
#include <iostream>
#include <algorithm>
using namespace std;
int arr[48];
int main()
{
    int t,n,i,temp;
    cin>>t;
    while( t-- )
    {
        cin>>n;
        for(i=0;i<n;++i)
            cin>>arr[i];
        sort(arr,arr+n);
        // 如果全是1,按照奇偶判斷誰獲勝
        if( arr[n-1]==1 )
        {
            if( n&1 )   cout<<"Brother"<<endl;
            else    cout<<"John"<<endl;
            continue;
        }
        // 異或加起來
        temp=arr[0]^arr[1];
        for(i=2;i<n;++i)
            temp^=arr[i];
        if( temp==0 )   cout<<"Brother"<<endl;
        else    cout<<"John"<<endl;
    }
    return 0;
}