天天看點

poj-1019-Number Sequence【思維】【規律】

題目連結:​​點選打開連結​​

Number Sequence

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 38616 Accepted: 11202

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another. 

For example, the first 80 digits of the sequence are as follows: 

11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3      

Sample Output

2
2      

思路:模拟分組,把 1 看做第 1 組,12 看做第 2 組,123 看做第 3 組……那麼第 i 組就是存放數字序列為  [ 1,i ] 的正整數,但第 i 組的長度不一定是 i

已知輸入查找第 n 個位的 n 的範圍為 (1 ≤ n ≤ 2147483647 ),那麼至少要有 31268 個組才能使得數字序列達到有第 2147483647 位

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
const int MAXN=40000;
int n;
unsigned len[MAXN]; // 記錄第 i個串的長度
unsigned pos[MAXN]; // 記錄第 i個串開始位置的下标
int ans[MAXN*30]; // 記錄最長的的串 
int main()
{
  len[1]=pos[1]=1;
  for(int i=2;i<MAXN;i++)
  {
    len[i]=len[i-1]+(int)log10(i*1.0)+1;
    pos[i]=pos[i-1]+len[i-1];
  }
  int cnt=1;
  for(int i=1;i<MAXN;i++)
  {
    int bit[100];
    int k=i,num=0;
    while(k)
    {
      bit[num++]=k%10;
      k/=10;
    }
    while(num--)
    {
      ans[cnt++]=bit[num]; 
    }
  }
  int t;
  scanf("%d",&t);
  while(t--)
  {
    scanf("%d",&n);
    int i;
    for(i=1;i<MAXN;i++)
    {
      if(pos[i]>=n)
        break;
    }
    if(pos[i]==n)
      puts("1");
    else
      printf("%d\n",ans[n-pos[i-1]+1]);
  }
  return 0;
}