題目:
Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.
The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:
S1, S2, ..., S13,
H1, H2, ..., H13,
C1, C2, ..., C13,
D1, D2, ..., D13,
J1, J2
where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.
Sample Input:
2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
Sample Output:
S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5
大緻題意:自動洗牌機,牌一開始按照順序依次排放,輸入一個number表示要洗牌的次數(repeat),輸入一個order(一串數字),即洗牌的規則。假設總共有5張牌S3, H5, C1, D13 and J2,輸入order為{4, 2, 5, 3, 1},表示第1張牌移到第4個位置,第二個移到第2個位置,第三個移到第5個位置……//自己題目意思也了解了好久啊……
思考:本來還在想因為要儲存中間過程,是不是能用棧來儲存。但是發現沒有後進先出。是以直接用多元數組了。
#include<iostream>
using namespace std;
#define N 20
#define MAXC 54
int main()
{
string ori[]={"S1","S2","S3","S4","S5","S6",
"S7","S8","S9","S10","S11","S12","S13",
"H1","H2","H3","H4","H5","H6",
"H7","H8","H9","H10","H11","H12","H13",
"C1","C2","C3","C4","C5","C6",
"C7","C8","C9","C10","C11","C12","C13",
"D1","D2","D3","D4","D5","D6",
"D7","D8","D9","D10","D11","D12","D13",
"J1","J2"};
int k,exchange[MAXC];
cin>>k;
for(int i=0;i<MAXC;i++){
cin>>exchange[i];
}
//建立多元數組,用來儲存中間的變化過程
string (*p)[MAXC];
p=new string[k][MAXC]();
for(int i=0,temp;i<k;i++){
for(int j=0;j<MAXC;j++){
if(i==0){
temp=exchange[j];
p[i][temp-1]=ori[j];//注意temp要減1,因為數組下标和位置差1——這裡調試了好久——調試的時候MAXC可以取小一點
}
else{
temp=exchange[j];
p[i][temp-1]=p[i-1][j];
}
}
}
k--;
for(int i=0;i<MAXC;i++){
if(i==MAXC-1){
cout<<p[k][i]<<endl;
}
else
cout<<p[k][i]<<" ";
}
return 0;
}