We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?
Input Specification:
Each input file contains one test case. For each test case, the first line contains NN (2\le N\le 10^42≤N≤10
4
), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and NN. Then in the following lines, the input is given in the format:
I c1 c2
where I stands for inputting a connection between c1 and c2; or
C c1 c2
where C stands for checking if it is possible to transfer files between c1 and c2; or
S
where S stands for stopping this case.
Output Specification:
For each C case, print in one line the word “yes” or “no” if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line “The network is connected.” if there is a path between any pair of computers; or “There are k components.” where k is the number of connected components in this network.
Sample Input 1:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S
Sample Output 1:
no
no
yes
There are 2 components.
Sample Input 2:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S
Sample Output 2:
no
no
yes
yes
The network is connected.
主要思路:
1、用vector存儲并查集中的每一個結點
2、合并兩個并查集時将結點個數少的并查集并入結點個數多的并查集(若結點個數多的并查集的高度很小,但結點個數少的并查集高度很大,該方法不合适)
AC代碼:
#include <iostream>
#include <vector>
using namespace std;
#define Max_Node 10001
typedef struct
{
int parent;
}Node;
int Find_Set(vector<Node> &set,int value)//尋找目前value所在的并查集的根結點
{
while (set[value].parent>0)
{
value=set[value].parent;
}
return value;
}
void Union_Set(vector<Node> &set,int value1,int value2)//合并兩個結點的并查集
{
int root1=Find_Set(set, value1);
int root2=Find_Set(set, value2);
if (set[root1].parent<set[root2].parent)//以root1為根的并查集的結點個數更多,将并查集結點個數少的合并到結點個數多的并查集
{
set[root2].parent=root1;
set[root1].parent--;
}else
{
set[root1].parent=root2;
set[root2].parent--;
}
}
bool Check_Set(vector<Node> &set,int value1,int value2)//查詢兩結點是否在同一個并查集
{
int root1=Find_Set(set, value1);
int root2=Find_Set(set, value2);
if (root1==root2)
{
return true;
}else
{
return false;
}
}
int Count_Set(vector<Node> &set)//查詢目前并查集的個數
{
int count=0;
for (int i=1; i<=set.size(); ++i)
{
if (set[i].parent<0)//parent小于0則該結點為一個并查集的根
{
count++;
}
}
return count;
}
int main()
{
int N=0;
cin>>N;
vector<Node> Set(N+1);
for (int i=1; i<=N; ++i)
{
Set[i].parent=-1;
}
char str;
int value1=0,value2=0;
while (1)
{
cin>>str;
if (str=='S')
{
break;
}else if(str=='I')
{
cin>>value1>>value2;
Union_Set(Set, value1, value2);
}else
{
cin>>value1>>value2;
if (Check_Set(Set, value1, value2))
{
cout<<"yes\n";
}else
{
cout<<"no\n";
}
}
}
int count=Count_Set(Set);
if (count>1)
{
cout<<"There "<<"are "<<count<<" components.";
}else
{
cout<<"The network is connected.";
}
return 0;
}
複制
