天天看點

poj1649 Rescue(BFS+優先隊列)

Rescue

Time Limit: 2 Seconds      

Memory Limit: 65536 KB

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8 

#.#####. 

#.a#..r. 

#..#x... 

..#..#.# 

#...##.. 

.#...... 

........

Sample Output

13

廣度優先搜尋找最短時間。

#include <stdio.h>
#include <queue>
#include <string.h>
using namespace std;
struct node
{
  int x,y,time;//x,y方格的位置。time目前所有的時間
  friend bool operator<(node a,node b)//優先隊列按照時間大小排序
  {
    return a.time>b.time;
  }
};
priority_queue<node>s;
char map[205][205];//地圖
int m,n,vis[205][205],escape,dir[4][2]={0,1,0,-1,1,0,-1,0};//vis标記,dir表示四個方向
bool judge(int x,int y)//判斷目前位置時候可以走
{
  if(x>=0&&y>=0&&x<n&&y<m&&!vis[x][y]&&map[x][y]!='#')
  return true;
  else
  return false;
}
int tonum(int x,int y)//把相應的道路,警衛換算成時間
{
  if(map[x][y]=='x')
  return 2;
  else
  return 1;
}
void bfs(int x,int y)//廣度優先搜尋
{
  node temp,temp1;
  temp.time=0,temp.x=x,temp.y=y;
  vis[x][y]=1;
  s.push(temp);//把temp入隊列
  while(!s.empty())
  {
    temp=s.top(),s.pop();
    temp1=temp;
    if(map[temp.x][temp.y]=='a')//提前結束循環,因為用的優先隊列,是以目前找到的肯定是最小的
    {
      escape=temp.time;
      break;
    }
    for(int i=0;i<4;i++)
    {
      int xx=temp.x+dir[i][0];
      int yy=temp.y+dir[i][1];
      if(judge(xx,yy))
      {
        vis[xx][yy]=1;//目前位置已浏覽 标記為1
        temp.x=xx,temp.y=yy,temp.time=temp.time+tonum(xx,yy);
        s.push(temp);//更新隊列
      }
      temp=temp1;//由于才判斷了一個方向,是以還需要temp1保持上次的位置
    }
  }
}
int main()
{
  while(scanf("%d %d",&n,&m)!=EOF)
  {
    escape=0;
    memset(vis,0,sizeof(vis));
    memset(map,0,sizeof(map));
    for(int i=0;i<n;i++)
    scanf("%s",map[i]);
    for(int i=0;i<n;i++)
    for(int j=0;j<m;j++)
    if(map[i][j]=='r')
    {
      bfs(i,j);
      break;
    }
    if(escape)
    printf("%d\n",escape);
    else
    printf("Poor ANGEL has to stay in the prison all his life.\n");
    while(!s.empty())//一定要記得清隊列。。剛剛wa了一次
    s.pop();
  }
}