天天看點

hdu1026 Ignatius and the Princess I(bfs+優先隊列+記錄路徑)

Ignatius and the Princess I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18858    Accepted Submission(s): 6093

Special Judge

Problem Description

The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).

2.The array is marked with some characters and numbers. We define them like this:

. : The place where Ignatius can walk on.

X : The place is a trap, Ignatius should not walk on it.

n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.

Input

The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.

Output

For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.

Sample Input

5 6
.XX.1.
..X.2.
2...X.
...XX.
XXXXX.
5 6
.XX.1.
..X.2.
2...X.
...XX.
XXXXX1
5 6
.XX...
..XX1.
2...X.
...XX.
XXXXX.      

Sample Output

It takes 13 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
FINISH
It takes 14 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
14s:FIGHT AT (4,5)
FINISH
God please help our poor hero.
FINISH      

Author

Ignatius.L

Recommend

We have carefully selected several similar problems for you:  

​​1072​​​ 

​​​1240​​​ 

​​​1372​​​ 

​​​1043​​​ 

​​​1254​​ 

​​Statistic​​ | ​​Submit​​ | ​​Discuss​​ | ​​Note​​

這道題做的我心力交瘁啊

bfs就不說了  關鍵是記錄路徑 我們可以把 當先移動的方向儲存在結構體中。

一直逾時 逾時 。逾時原因死活不明白。百度了許久看到有人說不要把變量定義在while循環裡面。改了還是逾時

最後發現 就在剛剛發現我的記錄路徑使用的int 數組,而且數組的範圍是10005 我的天。。

while循環了那麼多次  肯定要逾時了  。。。

#include <stdio.h>
#include <string.h>
#include <queue>
#include <iostream>
using namespace std;
struct node
{
  int x,y,cost;
  string step;//儲存路徑 
  friend bool operator<(node a,node b)
  {
    return a.cost>b.cost;
  }
};
int dir[4][2]={1,0,-1,0,0,1,0,-1};
bool vis[110][110];
int map[110][110];
int n,m,i,j;
bool limit(int x,int y)
{
  if(x<0||y<0||x>=n||y>=m||map[x][y]==-1) return false;
  return true;
}
node bfs()
{
  node n1,n2;
//  printf("%d %d %d %d",n1.x,n1.y,n1.cost,n1.index);
  priority_queue<node>s;
  n1.x=0;
  n1.y=0;
  n1.cost=0;
  s.push(n1);
  vis[0][0]=true;
  while(!s.empty())
  {
    n1=s.top();s.pop();
    if(n1.x==n-1&&n1.y==m-1)
    return n1;
    
    for(i=0;i<4;i++)
    {
      n2=n1;
      n2.x=n1.x+dir[i][0];
      n2.y=n1.y+dir[i][1];
      if(!limit(n2.x,n2.y)||vis[n2.x][n2.y]) continue;
      
      vis[n2.x][n2.y]=true;
      n2.step+=i+'0';//加入目前移動的方向 
      n2.cost+=map[n2.x][n2.y]+1;  
      if(n2.x==n-1&&n2.y==m-1) return n2;
      s.push(n2);
    }
  }
  n1.cost=-1;
  return n1;
}
int main()
{
  while(~scanf("%d %d",&n,&m))
  {
    memset(map,0,sizeof(map));
    memset(vis,false,sizeof(vis));
    char str[150];
    for(i=0;i<n;i++)
    {
      scanf("%s",str);
      for(j=0;j<m;j++)
      {
        if(str[j]=='.') map[i][j]=0;
        else if(str[j]=='X') map[i][j]=-1;
        else map[i][j]=str[j]-'0';
      }
    }
    
    node res=bfs();
    //輸出路徑   
    if(res.cost==-1)
    {
      printf("God please help our poor hero.\nFINISH\n");
      continue;
    }
    printf("It takes %d seconds to reach the target position, let me show you the way.\n",res.cost);
    int i=-1;
    int st_x=0,st_y=0,ed_x,ed_y,cost=0,c;
    while(++i<res.step.length())
    {
      ed_x=st_x+dir[res.step[i]-'0'][0];
      ed_y=st_y+dir[res.step[i]-'0'][1];
      cost++;
      printf("%ds:(%d,%d)->(%d,%d)\n",cost,st_x,st_y,ed_x,ed_y);
      if(map[ed_x][ed_y]>=1&&map[ed_x][ed_y]<=9)
      {
        c=map[ed_x][ed_y];
        while(c--)
        {
          printf("%ds:FIGHT AT (%d,%d)\n",++cost,ed_x,ed_y);
        }
      }
      st_x=ed_x;
      st_y=ed_y;
    }
    printf("FINISH\n");
  }
  return 0;
}