天天看點

HDU——1009 FatMouse' Trade FatMouse' Trade

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 54945    Accepted Submission(s): 18426

Problem Description FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
        

Sample Output

13.333
31.500
  
  

  
  

  
  
   貪心,最優裝載問題
  
  

  
  
   #include<iostream>
#include<algorithm>
#include<stdio.h>

using namespace std;

struct data
{
    int x;
    int y;
    double z;
}a[10010];

bool comp(data a,data b)
{
    return a.z>b.z;
}

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==-1&&m==-1)
            break;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
            a[i].z=(double)a[i].x/(double)a[i].y;
        }
        sort(a,a+m,comp);
        double sum=0.0;
        for(int i=0;i<m;i++)
        {
            if(a[i].y>(double)n)
            {
                sum+=(double)a[i].x/(double)a[i].y*(double)n;
                break;
            }
            else
            {
                sum+=a[i].x;
                n-=a[i].y;
            }
        }
        printf("%.3f\n",sum);
    }
}
        

繼續閱讀