天天看點

POJ 1125 Stockbroker Grapevine(最短路&Floyd)

Stockbroker Grapevine http://poj.org/problem?id=1125

Time Limit:  1000MS

Memory Limit: 10000K

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 

It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0      

Sample Output

3 2
3 10      

學英語=v=: Each person is numbered 1 through to the number of stockbrokers. 

每個人的編号為1至股票經紀人數目。(也就是行數)

思路: 1. 有向圖,無自環,使用鄰接矩陣存儲時間。 2. 由于要算每兩點之間的最短路,故使用Floyd算法。 3. 算完後比較一下就行。

完整代碼:

/*0ms,204KB*/

#include<cstdio>
#include<cstring>
using namespace std;
const int inf = 1000;//ok

int dist[101][101];
int i, j, k;
int n;//股票經紀人個數
int maxtime, time;

void floyd()
{
	for (k = 1; k <= n; k++)
		for (i = 1; i <= n; i++)
			//注意,隻有無向圖(雙向邊權相等)才可以使用for(j=i+1;j<=n;j++),這是因為無向圖的鄰接矩陣有對稱性
			for (j = 1; j <= n; j++)
				if (i != j && dist[i][j] > dist[i][k] + dist[k][j]) //判斷i!=j是因為本題不存在自環
					dist[i][j] = dist[i][k] + dist[k][j];
	int fastest_person;
	time = inf;
	for (i = 1; i <= n; i++)//各通路源點
	{
		maxtime = 0;
		for (j = 1; j <= n; j++)
			if (i != j && dist[i][j] > maxtime)//尋找i到j的最長時間
				maxtime = dist[i][j];
		if (maxtime < time)
		{
			time = maxtime;//尋找所有最長時間中的最短時間
			fastest_person = i;//記錄此人
		}
	}
	if (time < inf)
		printf("%d %d\n", fastest_person, time);
	else
		printf("disjoint\n");
}

int main(void)
{
	while (scanf("%d", &n), n)
	{
		memset(dist, 1, sizeof(dist));//全部初始化為16843009,夠大了
		for (i = 1; i <= n; i++)
		{
			int pair;
			scanf("%d", &pair);
			while (pair--)
			{
				int contact;
				scanf("%d%d", &contact, &time);//i的接觸人,接觸時間(邊權)
				dist[i][contact] = time;
			}
		}
		floyd();
	}
	return 0;
}