天天看點

Lifting the Stone(※※※多邊形重心)

                                                                       Lifting the Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3290    Accepted Submission(s): 1361

Problem Description

There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line. 

Output

Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway. 

Sample Input

2

4

5 0

0 5

-5 0

0 -5

4

1 1

11 1

11 11

1 11

Sample Output

0.00 0.00

6.00 6.00

Source

Central Europe 1999 

Recommend

Eddy

計算多邊形重心方法:

(1)劃分多邊形為三角形:

以多邊形的一個頂點V為源點(V可取輸入的第一個頂點),作連結V與所有非相鄰頂點的線段,即将原N邊形或分為(N-2)個三角形;

(2)求每個三角形的重心和面積:

設某個三角形的重心為G(cx,cy),頂點坐标分别為A1(x1,y1),A2(x2,y2),A3(x3,y3),則有cx = (x1 + x2 + x3)/3.同理求得cy。求面積的方法是s =  ( (x2 - x1) * (y3 - y1) - (x3 - x1) * (y2 - y1) ) / 2,當A1,A2,A3順時針排列時取-,否則取正(此定理不證)。事實上,在求每個三角形時不需要辨識正負,之後有方法抵消負号,見下述。

(3)求原多邊形的重心:

公式:cx = (∑ cx[i]*s[i]) / ∑s[i];  cy = (∑ cy[i]*s[i] ) / ∑s[i];其中(cx[i], cy[i]), s[i]分别是所劃分的第i個三角形的重心坐标和面積。由題“ connect the points in the given order”知每個s[i]的正負号相同,故而∑ cx[i]*s[i]能與∑s[i]消号,是以根本不需要在第(2)步判斷每個s[i]的正負。另外,在(2)中求每個重心坐标時要除以3,實際上不需要在求每個三角形坐标時都除以3,隻需要求出∑ cx[i]*s[i]後一次性除以3即可。即是多邊形重心坐标變為:cx = (∑ cx[i]*s[i]) / (3*∑s[i]);  cy = (∑ cy[i]*s[i] ) / (3*∑s[i]);

總結:

每個三角形重心:cx = x1 + x2 + x3;cy同理。

每個三角形面積:s =  ( (x2 - x1) * (y3 - y1) - (x3 - x1) * (y2 - y1) ) / 2;

多邊形重心:cx = (∑ cx[i]*s[i]) / (3*∑s[i]);  cy = (∑ cy[i]*s[i] ) / (3*∑s[i]);

AC CODE:

#include <iostream>
#include <cstdio>
using namespace std;

int T, N, x[3], y[3];
double sumx, sumy, sumarea;

int main()
{
    scanf("%d", &T);
    while(T--)
    {
        sumx = sumy = sumarea = 0.0;
        scanf("%d", &N);
        scanf("%d %d %d %d", x, y, x+1, y+1);
        N -= 2;
        while(N--)
        {
            scanf("%d %d", x+2, y+2);
            //求新添加的三角形的面積
            double s = ((x[1] - x[0]) * (y[2] - y[0]) - (x[2] - x[0]) * (y[1] - y[0])) / 2.0;
            //求∑x[i]*s[i]和∑y[i]*s[i]
            sumx += ((x[0] + x[1] + x[2]) * s);
            sumy += ((y[0] + y[1] + y[2]) * s);
            //求總面積
            sumarea += s;

            x[1] = x[2];
            y[1] = y[2];
        }
        printf("%.2lf %.2lf\n", sumx / sumarea / 3, sumy / sumarea / 3);
    }
    return 0;
}
           

繼續閱讀