天天看點

HDU——1051&&POJ——1065 Wooden Sticks Wooden Sticks

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15183    Accepted Submission(s): 6232

Problem Description There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1
        

Sample Output

2
1
3
        

Source Asia 2001, Taejon (South Korea)

輸入一堆資料,兩個一對,前一對的兩個值小于下面的一對時,算是一種情況,統計總共有多少對

#include<iostream>

#include<stdio.h>

#include<string.h>

#include<math.h>

#include<ctype.h>

#include<stdlib.h>

#include<string>

#include<algorithm>

#include<vector>

#include<set>

#include<map>

#include<list>

#include<queue>

#include<stack>

#include<iomanip>

#include<numeric>

#include <istream>     //基本輸入流

#include <ostream>     //基本輸出流

#include <sstream>     //基于字元串的流

#include <utility>     //STL 通用模闆類

#include <complex.h>   //複數處理

#include <fenv.h>    //浮點環境

#include <inttypes.h>  //整數格式轉換

#include <stdbool.h>   //布爾環境

#include <stdint.h>   //整型環境

#include <tgmath.h>   //通用類型數學宏

#define L(a,b,c) for(int a = b;a >= c;a --)

#define M(a,b,c) for(int a = b;a < c;a ++)

#define N(a,b) memset(a,b,sizeof(a));

const int MAX=100000000;

const int MIN=-MAX;

typedef int T;

typedef double D;

typedef char C;

using namespace std;

struct data

{

    int x,y;

    bool t; ///标記有沒有參加比較

} a[100010];

int comp(data x,data y)

{

    if(x.y == y.y)

        return x.x < y.x;

    else

        return x.y < y.y;

}

int n;

int main()

{

    int t;

    scanf("%d",&t);

    while(t--)

    {

        scanf("%d",&n);

        M(i,0,n)

        {

            scanf("%d%d",&a[i].x,&a[i].y);

            a[i].t=0;

        }

        sort(a,a+n,comp);

        int sum=0;

        M(i,0,n) ///貪心思想

        {

            if(!a[i].t)

            {

                ++sum;

                int start=a[i].x;

                int end=a[i].y;

                M(j,i+1,n)

                if(! a[j].t)

                    if(a[j].x >= start&&a[j].y >= end)

                    {

                        a[j].t=1;

                        start=a[j].x;

                        end=a[j].y;

                    }

            }

        }

        cout<<sum<<endl;

    }

    return 0;

}

繼續閱讀