An Easy Task
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14152 Accepted Submission(s): 9041
Problem Description Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?
Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.
Note: if year Y is a leap year, then the 1st leap year is year Y.
Input The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
Output For each test case, you should output the Nth leap year from year Y.
Sample Input
3
2005 25
1855 12
2004 10000
Sample Output
2108
1904
43236
Hint
We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.
#include<stdio.h>
int runy(int y)
{
return ((y%4==0&&y%100!=0)||y%400==0);
}
int main()
{
int T,n,y,i,a;
while(scanf("%d",&T)!=EOF)
{
while(T--)
{
scanf("%d %d",&y,&n);
a=y%4;
if(a)
y-=a;
else
y-=4;
for(i=1;i<=n;i++)
{
y+=4;
if(runy(y)==0)
y+=4;
}
printf("%d\n",y);
}
}
return 0;
}