天天看點

LightOJ 1294 - Positive Negative Sign (規律)

1294 - Positive Negative Sign

Description

Given two integers: n and m and n is divisible by 2m, you have to write down the first n natural numbers in the following form. At first take first m integers and make their sign negative, then take next m integers and make their sign positive, the next m integers should have negative signs and continue this procedure until all the n integers have been assigned a sign. For example, let n be 12 and m be 3. Then we have

-1 -2 -3 +4 +5 +6 -7 -8 -9 +10 +11 +12

If n = 4 and m = 1, then we have

-1 +2 -3 +4

Now your task is to find the summation of the numbers considering their signs.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing two integers: n and m (2 ≤ n ≤ 109, 1 ≤ m). And you can assume that n is divisible by 2*m.

Output

For each case, print the case number and the summation.

Sample Input

2

12 3

4 1

Sample Output

Case 1: 18

Case 2: 2

題意:輸入n和m且  n==2m,然後m個數為一組正負交替,像樣例一樣,然後求和

思路:m個正和m個負的和為m*m,然後這樣組合的個數為n/(2*m),那麼最後的答案就是m*m*n/(2*m)

ac代碼:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<stack>
#include<iostream>
#include<algorithm>
#define fab(a) (a)>0?(a):(-a)
#define MAXN 100010
#define INF 0xfffffff
#define LL long long
using namespace std;
int main()
{
	LL m,n;
	int t;
	int cas=0;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld%lld",&n,&m);
		LL ans;
		ans=m*m*(n/(2*m));
		printf("Case %d: ",++cas);
		printf("%lld\n",ans);
	}
	return 0;
}
           

繼續閱讀