天天看點

Poj 1144 Network【Tarjan求割點】

Network

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11905 Accepted: 5517

Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is 

possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure 

occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated 

by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5

5 1 2 3 4

6

2 1 3

5 4 6 2

Sample Output

1

2

Hint

You need to determine the end of one line.In order to make it's easy to determine,there are no extra blank before the end of each line.

Source

Central Europe 1996

題目大意:

一個電話公司建立了一個新的電話網,他們用1——N的整數标記了一些地方,每個地方有唯一的編号,網絡中的每條電纜雙向連接配接了兩個地方,從每個地方可以通過電纜連接配接到任意其他的地方,因為它們之間不一定要有直接相連的電纜,可以通過其他的電纜間接連接配接,有的時候某個地方的電力可能會中斷,進而導緻這個地方無法被連接配接,電話公司意識到了某些地方的電力中斷可能會導緻其他地方也無法互相連接配接,把這些地方叫做關鍵點,是以他們決定寫一個程式去找到這些地方。

思路:Tarjan求割點。

推薦部落格:http://www.cnblogs.com/en-heng/p/4002658.html

AC代碼:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int head[100000];
int dfn[100000];
int low[100000];
int ans[100000];
struct EdgeNode
{
    int to;
    int w;
    int next;
}e[100000];
int cont,cnt,root;
void add(int from,int to)
{
    e[cont].to=to;
    e[cont].next=head[from];
    head[from]=cont++;
}
void init()
{
    cont=0;
    cnt=1;
    root=1;
    memset(head,-1,sizeof(head));
    memset(ans,0,sizeof(ans));
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
}
// 樹邊 low[u]=min(low[u],low[v]);
// 回邊 low[u]=min(low[u],dfn[v]);
void Tarjan(int u,int from)
{
    dfn[u]=low[u]=cnt;
    cnt++;
    int sum=0;
    for(int k=head[u];k!=-1;k=e[k].next)
    {
        int v=e[k].to;
        if(dfn[v]==0)
        {
            Tarjan(v,u);
            low[u]=min(low[u],low[v]);
            if(u==root)
            {
                sum++;
                if(sum>1)ans[u]=1;
            }
            if(low[v]>=dfn[u]&&u!=root)
            {
                ans[u]=1;
            }
        }
        else if(v!=from)low[u]=min(low[u],dfn[v]);
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)break;
        init();
        int u;
        while(~scanf("%d",&u))
        {
            if(u==0)break;
            int v;
            char tmp;
            scanf("%c",&tmp);
            while(tmp!='\n')
            {
                scanf("%d%c",&v,&tmp);
                add(u,v);
                add(v,u);
            }
        }
        Tarjan(1,-1);
        int output=0;
        for(int i=1;i<=n;i++)
        {
            if(ans[i]==1)
            {
                output++;
            }
        }
        printf("%d\n",output);
    }
}