天天看點

A/B----乘法逆元 A/B

A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5491    Accepted Submission(s): 4275

Problem Description 要求(A/B)%9973,但由于A很大,我們隻給出n(n=A%9973)(我們給定的A必能被B整除,且gcd(B,9973) = 1)。  

Input 資料的第一行是一個T,表示有T組資料。

每組資料有兩個數n(0 <= n < 9973)和B(1 <= B <= 10^9)。  

Output 對應每組資料輸出(A/B)%9973。  

Sample Input

2
1000 53
87 123456789
        

Sample Output

7922
6060
        

Author xhd   題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=1576

逆元的水題,a/b等于a*(b的逆元);

代碼:

#include <cstdio>
#include <cstring>
#include <iostream>
#define LL long long
using namespace std;
const int p=9973;
LL inv(LL t, LL p) {
    return t==1?1:(p-p/t)*inv(p%t,p)%p;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        LL n,b;
        scanf("%lld%lld",&n,&b);
        LL x=inv(b%p,p);
        printf("%lld\n",n*x%p);
    }
}