Alice is providing print service, while the pricing doesn\'t seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It\'s easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 105). The second line contains 2n integers s1, p1, s2, p2, ..., sn, pn (0=s1 < s2 < ... < sn ≤ 109, 109 ≥ p1 ≥ p2 ≥ ... ≥ pn ≥ 0). The price when printing no less than si but less than si+1 pages is pi cents per page (for i=1..n-1). The price when printing no less than sn pages is pn cents per page. The third line containing m integers q1 .. qm (0 ≤ qi ≤ 109) are the queries.
<h4< dd="">Output
For each query qi, you should output the minimum amount of money (in cents) to pay if you want to print qi pages, one output in one line.
<h4< dd="">Sample Input
1
2 3
0 20 100 10
0 99 100
<h4< dd="">Sample Output
0
1000
1000
題意:
就是說有一個人要列印東西,如果列印s頁以上每張收費p元,讓你求出來列印東西最少花錢多少。
但是要注意如果2頁以上收a元,5頁以上收b元,那麼大于等于1小于5的時候才可以收a元每頁,如果要是了解成1頁到無窮多頁都收費為a元,那就尴尬了(好像就是我)
然後就要注意的是,題目上說了s1<s2<....<sn,是以就不需要排序
具體看代碼:
下面用到了關于二分的函數,不知道的話看連結:https://blog.csdn.net/qq_40160605/article/details/80150252
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
const ll INF=1e18+5;
ll min(ll x,ll y)
{
return x>y ? y : x;
}
ll first[100005],second[100005],dp[100005];
int main()
{
ll t;
scanf("%lld",&t);
while(t--)
{
ll n,m,minn=INF;
memset(dp,0,sizeof(dp));
scanf("%lld%lld",&n,&m);
for(ll i=0;i<n;++i)
{
scanf("%lld%lld",&first[i],&second[i]);
minn=min(minn,second[i]);
}
dp[n]=INF;
for(ll i=n-1;i>=0;--i) dp[i]=min(dp[i+1],second[i]*first[i]);
while(m--)
{
ll q;
scanf("%lld",&q);
if(q>=first[n-1])
{
printf("%lld\n",q*second[n-1]);
continue;
}
ll temp=upper_bound(first,first+n,q)-first;
ll ans=min(dp[temp],second[temp-1]*q);
printf("%lld\n",ans);
}
}
return 0;;
}