天天看點

HDU 1097 A hard puzzle(快速幂取模)                                                                        A hard puzzle

                                                                        A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 38370    Accepted Submission(s): 13705

Problem Description lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.

this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

Input There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

Output For each test case, you should output the a^b's last digit number.

Sample Input

7 66
8 800
        

Sample Output

9
6
        

Author eddy

題解:輸入a,b,求a^b的最後一位。

    快速幂取模。

AC代碼:

#include<iostream>
#include<cstdio>
typedef long long LL;

int qmod(LL a,LL b,int c)
{
	int ans=1;
	a=a%c;
	while(b>0){
		if(b&1)
		ans=(ans*a)%c;
		b=b>>1;
		a=(a*a)%c;
	}
	return ans;
}

int main()
{
	LL a,b;
	while(~scanf("%lld%lld",&a,&b)){
		printf("%d\n",qmod(a,b,10));
	}
	return 0;
}