Oulipo (KMP算法)
題目連結:HDU-1686
題目:
Oulipo
Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
題目大意:在字元串T中找出字元串W出現的次數。
例:
W:AZA
T: AZAZAZA
T中包含AZAZAZA,AZAZAZA,AZAZAZA共3個,是以答案為3
AC代碼:
#include<iostream>
#include<cstring>
using namespace std;
char w[10005];
char t[1000005];
int nex[10005];
void getnext(int nex[],char w[],int l)//計算next數組,l為字元串w的長度
{
int i=0,j = -1;
nex[0] = -1;
while(i<l)
{
if(j == -1||w[i]==w[j])
{
i++;
j++;
nex[i]=j;
}
else
j=nex[j];
}
}
int kmp(char t[],char w[],int l1,int l2)
{
int ans=0;
int i=0,j=0;
while(i<l1)//周遊1遍字元串t
{
if(j==-1||t[i]==w[j])
{
i++;
j++;
}
else
j=nex[j];
if(j==l2)
{
ans++;
j=nex[j];//完成比對後進入下一次比對,直到周遊完字元串t
}
}
return ans;
}
int main()
{
int q;
cin >> q;
while(q--)
{
cin >> w;
cin >> t;
getnext(nex,w,strlen(w));
cout << kmp(t,w,strlen(t),strlen(w)) << endl;
}
return 0;
}