原題
This time, you are supposed to find A*B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
求兩個多項式的乘積,直接模拟。
跳過無效項即可,題目沒說清,四舍五入後為0.0的項不顯示。
代碼:
#include <iostream>
using namespace std;
int main()
{
int k1,k2,k=0; //多項式1、2、乘積有效項
double poly1[1001]; //多項式1,标号對應次數
double poly2[1001]; //多項式2
double poly[2001]; //乘積
int i,j,exp;
double coe;
for(i=0;i<1001;i++) //初始化
{
poly1[i]=0.0;
poly2[i]=0.0;
}
for(i=0;i<2001;i++)
poly[i]=0.0;
cin>>k1;
for(i=0;i<k1;i++) //輸入
{
cin>>exp>>coe;
poly1[exp]=coe;
}
cin>>k2;
for(i=0;i<k2;i++)
{
cin>>exp>>coe;
poly2[exp]=coe;
}
for(i=0;i<1001;i++) //相乘
for(j=0;j<1001;j++)
poly[i+j]+=poly1[i]*poly2[j];
i=2000;
while(i>=0&&poly[i]<0.05&&poly[i]>-0.05)
i--;
if(i<0)
cout<<0;
else
{
j=i;
while(j>=0) //統計有效項
{
if(poly[j]>=0.05||poly[j]<=-0.05)
k++;
j--;
}
cout<<k;
cout<<fixed;
cout.precision(1);
while(i>=0) //輸出
{
if(poly[i]>=0.05||poly[i]<=-0.05)
cout<<" "<<i<<" "<<poly[i];
i--;
}
}
return 0;
}