Find them, Catch them
Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)
Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:
1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.
2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4
Sample Output
Not sure yet.
In different gangs.
In the same gang.
Source
POJ Monthly--2004.07.18
題目大意:
T組測試資料,n個人,m組詢問,2個幫派,D a b 表示 a,b 不在同一幫派 ,A a b表示查詢a和b的關系。
解題思路:
并查集。将每個人對應兩個節點,分屬于兩個幫派。1~n表示幫派1中的,n+1~2n表示幫派2中的。若知道a和b不是同一幫的,那麼将a和b+n放到一個集合中,b和a+n放到一個集合中。并查集查詢a和b的關系時,如果a與b+n在一個集合中,則說明他們不在同一幫;若a和b在同一集合,則在同一幫;否則說明他們關系不确定。連線時交叉連,即保證間隔兩人在同一集合。即敵人的敵人是朋友。
參考代碼:
#include <cstdio>
using namespace std;
const int MAXN = 200010;
int N, M, nCase, father[MAXN], rank[MAXN];
int find_set(int x) {
return father[x] = father[x] == x ? x : find_set(father[x]);
}
void union_set(int x, int y) {
int a = find_set(x), b = find_set(y);
if (rank[a] < rank[b]) {
father[a] = b;
} else {
father[b] = a;
if (rank[a] == rank[b]) {
rank[a]++;
}
}
}
void init() {
for (int i = 1; i <= 2*N; i++) {
father[i] = i;
rank[i] = 1;
}
}
void solve() {
for (int i = 0; i < M; i++) {
char op;
int a, b;
getchar();
scanf("%c%d%d", &op, &a, &b);
if (op == 'D') {
union_set(a, b+N);
union_set(b, a+N);
} else if (op == 'A') {
if (find_set(a) == find_set(b+N)) {
printf("In different gangs.\n");
} else if (find_set(a) == find_set(b)) {
printf("In the same gang.\n");
} else {
printf("Not sure yet.\n");
}
}
}
}
int main() {
scanf("%d", &nCase);
while (nCase--) {
scanf("%d%d", &N, &M);
init();
solve();
}
return 0;
}