天天看點

HDU 2401 Baskets of Gold Coins(數學題)

                                  Baskets of Gold Coins

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2066    Accepted Submission(s): 1241

Problem Description

You are given N baskets of gold coins. The baskets are numbered from 1 to N. In all except one of the baskets, each gold coin weighs w grams. In the one exceptional basket, each gold coin weighs w-d grams. A wizard appears on the scene and takes 1 coin from Basket 1, 2 coins from Basket 2, and so on, up to and including N-1 coins from Basket N-1. He does not take any coins from Basket N. He weighs the selected coins and concludes which of the N baskets contains the lighter coins. Your mission is to emulate the wizard's computation.

Input

The input file will consist of one or more lines; each line will contain data for one instance of the problem. More specifically, each line will contain four positive integers, separated by one blank space. The first three integers are, respectively, the numbers N, w, and d, as described above. The fourth integer is the result of weighing the selected coins.

N will be at least 2 and not more than 8000. The value of w will be at most 30. The value of d will be less than w.

Output

For each instance of the problem, your program will produce one line of output, consisting of one positive integer: the number of the basket that contains lighter coins than the other baskets.

Sample Input

10 25 8 1109

10 25 8 1045

8000 30 12 959879400

Sample Output

2

10

50

Source

​​ACM/ICPC 2008 Warmup(2)——測試帳号(杭州) ​​

題意:

有N個籃子,編号1—N,籃子中有很多金币,每個重w.但是有一個編号的籃子中,每個金币重w-d.女巫從第一個籃子中拿1個金币,第二個籃子中拿2個……第N-1中拿N-1個,第N中不拿,給出這些金币的總重量s,問:是第幾個籃子中的金币重量較輕?

題解:

先求1—N籃子金币應有的總重量yuan=w*(1+n-1)(n-1)/2,然後求內插補點cha=原-s ,再除以金币重量內插補點d則得出輕金币的個數。若為0,則必在編号N的籃子中;若不為0,得到較輕金币的個數,即為所求編号。

AC代碼:

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
typedef long long LL;
using namespace std;
int main()
{
    int n,w,d,s,cha,yuan,ans;
    while(cin>>n>>w>>d>>s)
    {
        yuan=w*n*(n-1)/2;
        cha=yuan-s;
        ans=cha/d;
        if(ans==0)   //其實就是差(cha)等于0 
            cout<<n<<endl;
        else
            cout<<ans<<endl;
    }
    return 0;

}