天天看點

1140 Look-and-say Sequence (20 分)

1. 題目

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...
           

where

D

is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one

D

in the 1st number, and hence it is

D1

; the 2nd number consists of one

D

(corresponding to

D1

) and one 1 (corresponding to 11), therefore the 3rd number is

D111

; or since the 4th number is

D113

, it consists of one

D

, two 1's, and one 3, so the next number must be

D11231

. This definition works for

D

= 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit

D

.

Input Specification:

Each input file contains one test case, which gives

D

(in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of

D

.

Sample Input:

1 8
           

Sample Output:

1123123111
           

2. 題意

外觀數列,如下案例:

D, D1, D111, D113, D11231...

其中

D

是一個[0, 9]範圍内不等于1的整數;

數列第2項:表示第1項有1個

D

,是以為

D1

數列第3項:表示第2項中有1個

1

和1個

D

,是以為

D111

數列第4項:表示第3項中有1個

D

和3個

1

,是以為

D113

數列第5項:表示第4項中有1個

D

,2個

1

和1個

3

,是以為

D11231

...

數列第n項:...

3. 思路

4. 代碼

#include <iostream>
#include <string>

using namespace std;

string res;

void lookAndSay()
{
	char ch = res[0];
	string temp = "";
	int cnt = 1;
	for (int i = 1; i < res.length(); ++i)
	{
		if (res[i] == ch)
		{
			// 計數連續相等字元的個數 
			cnt++;
		} else
		{
			// 當出現字元不一緻時,計數結束,并将字元和個數加入結果temp字元串 
			temp += ch + to_string(cnt);
			ch = res[i];
			cnt = 1;
		}
	}
	// 字元串最後一位沒有進行計數操作,額外進行一次操作 
	temp += ch + to_string(cnt);
	// 将最新外觀數列temp指派給res 
	res = temp;
}

int main()
{
	int n;
	cin >> res >> n;
	// 外觀數列的第一項即為本身,不需要進行額外計算 
	n -= 1;	
	while (n--)
	{
		lookAndSay();
	}
	cout << res << endl;
	return 0;
}