天天看點

1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0           

Sample Output:

Case #1: false
Case #2: true
Case #3: false           

 思路:根據a,b,sum的正負判斷是否溢出。注意:用cin輸入會造成最後一個測試點過不去!!!,換成scanf輸入

#include<bits/stdc++.h>
using namespace std;
const int maxn=1000010;

int main(){
    int n;
    long long a,b,c;
    long long sum=0;
    scanf("%lld",&n);
    for(int i=0;i<n;i++){
        sum=0;
        scanf("%lld %lld %lld",&a,&b,&c);
        sum=a+b;
        if(a>0&&b>0&&sum<0){
            printf("Case #%d: true\n",i+1);
        }
        else if(a<0&&b<0&&sum>=0){
            printf("Case #%d: false\n",i+1);
        }
        else if(sum>c){
            printf("Case #%d: true\n",i+1);
        }
        else{
            printf("Case #%d: false\n",i+1);
        }
    }
    return 0;
}      

繼續閱讀